Midi Instrument Track no sound on playback

Hi guys,

So I’ve recorded midi into cubase pro with an external midi keyboard and used the instrument track option in cubase. It records the midi fine but when I try to playback the recording there’s no sound … ?

Any ideas?



Did you record to the Instrument track directly? Or do you have any MIDI track?

How is the output routing of the Instrument track? Can you hear imported Audio loop for example?

Hi Martin, thanks for your reply…

I’ve recorded directly to the Instrument track…

Not really sure about the routing but I’ve attached a picture with the channel routing …

Sorry … kind of a novice here …


There is some signal, only little, but there is something, as I can see on the meters. Is the Instrument set properly?

Sorry, I didn’t understand what you meant first, but yes, there is a strong signal coming in from the instrument, I’ve taken another screen shot now…

The instrument is set properly as far as I can see… Set up a new virtual instrument in cubase in midi manager and also set connections in external instrument option in studio setup dialog box.


What settings is different comparison the 1st and the 2nd screenshot, please? ON the 2nd one, I can see strong signal on the Channels, not on the 1st one. Can you hear something with the 2nd screenshot?

If not, could you attach a screenshot of the Audio Connections > Outputs, please?

On the first screenshot there’s no signal coming in because I’m not playing anything … on the second screenshot I’m playing the external instrument … I am hearing what I’m playing when I’m recording … when I’m playing back the recording I can’t hear anything … the recording is midi just to let you know .
Thanks for the help


Could you make a screenshot, when you playing it back? So at the state when it doesn’t work, please?

A Solution to a problem of: " [Mute/solo greyed out on Project window]".
The External Midi Instrument does not play back after recording even though you can hear it while recording (which is possible when you have MIDI Local “on” on your external device).

Hi there,

I am on a Mac M1 , OS: Monterey/Cubase 12.

The “Mute/Solo” greyed out=not active make the track to not play back the midi sounds. The External Midi Instrument is not properly connected even though it shows that it is.

In order to make the “MUTE/SOLO” back Active/black (not greyed out) on a track with an external Midi Instrument please Try the following solution:
While having the session opened with the existing problem:

  1. Turn OFF (power off) the External Midi Instrument (while the program is running) and quit without saving the Cubase.
  2. Restart the Cubase 12.
    Start the session back again. At the startup you will get a window with a “problem” of missing/disconnected Midi instrument- push “OK” and proceed to start the session in question in Cubase 12.
  3. Once the DAW opens, the track with previously greyed out “Mute/Solo” should be now Active: “Mute/Solo” should be in Black.
  4. Now Turn “on” (power on) the External Midi Instrument in question, wait until it fully loads the sounds and play the session/instrument.
    Everything should work now Fine :slight_smile:

Save the session.


  • Pawel