MIDI is being detected in Nuendo but is not being routed to my instruments

After several hours of trying to get my midi keyboard and korg nanokontrol to communicate with my instruments in Nuendo, I cannot figure out why it is not working. Everything is working fine when I test on cubase, and from what I have checked all the settings appear to be the same. In the bottom right corner I can see that midi is being detected by nuendo… the midi from both my keyboard and nanokontrol are just not influencing any of the instruments. I’ll include photos of my current settings. Any help would be greatly appreciated!
Cheers

In the track header, click the little loudspeaker icon for monitoring.

I missed that! Thanks so much for the help!

You’re welcome. Keep in mind that there are many different ways to customise Nuendo’s behaviour regarding manual and/or automatic input monitoring, both for audio and MIDI.