MIDI is out of sync (delayed) from audio tracks

Thanks to people on this forum for getting me going. I do have midi working now but it is out of sync with the rest of the tracks (which are all audio tracks).

I recorded the audio with the metronome. If I turn it on, the audio tracks are still in sync with the metronome. But the midi track that I “recorded” by plotting on the key editor, is delayed. The attached JPG shows a screenshot of two tracks; one is the midi and one is an egg shaker. As you can see they are both pretty close to the actual time of the beat, but the midi is exactly on and the egg shaker is a little after the beat (human error). However when mute all other tracks and listen closely, the midi event (which is a bass drum) sounds AFTER the egg shaker.

I figured this must be what that latency stuff is all about. So I experimented with changing the latency in the control panel for my audio device (Presonus Inspire). This popped up some error messages and did not resolve the problem.

The latency has been set to 10ms all along, until I just tried changing it to 3ms. There seems to be no difference between the two; I still get that delay on the midi and I hear that bass drum after the egg shaker.

If anyone knows how I can fix this I will be forever indebted to you and I won’t forget you when I make it to the top (which top? the very top!)

gary in vermont

What are you controlling with that midi track? A software instrument or hardware?

Try enabling ‘use system timestamp’ in device setup.

edit: This is a good start

All I did was double click on the track to open up a blank key editor and then plot the notes on the graph. I have no midi hardware/instrument. I plot the drum beat right on the beat of the measure, which is when the metronome sounds, but the drumbeat that I plotted plays afterwards.

I will try to find the device setting you are talking about. thanks

Well something has to be playing that drumsound? :wink:
You probably loaded something like HalionOne on the miditrack, but it doesn’t really matter anyway.

Try the system timestamp checkbox :slight_smile:

ok, attached is a screenshot of the current settings on the midi track and the VST instruments… I’ve tried a bunch of settings there, some work, some don’t; this one at least gets the sound to play and record on to the track. Not sure if that tells you anything…

I’m going to try the timestamp setting tonight (just got back from thanksgiving). thanks again

Seems my software version doesn’t have the “use system timestamp” option. The article states:

“from Cubase SE3, SL and SX 3.1 and Nuendo 3.1 onwards, a separate ‘Use system timestamp’ option has been available in the Windows MIDI page, so even in multi-interface systems using both DirectMusic and Windows MIDI drivers you can cure timing problems individually. You can find these timestamp tick-boxes by opening the Device Setup window from the Devices menu — there’s one in the DirectMusic page and a second in the Windows MIDI page of the MIDI section.”

I looked in my device setup and couldn’t find anything like that anywhere :frowning:

You need to use the Emulated MIDI Ports. See the MIDI Timing link in my sig.

Thanks for the advice. I read the article and tried to follow the directions. however, the file “enableemulated” is not there. The article says it should be in a folder called “Cubase/Nuendo/Sequel” but i don’t have that folder.

I do have a folder called “Cubase LE/Midi Port Enabler” and there is one file in there called “ignoreportfilter”. Do you think that one will help me?

Yes, move the Ignore Port Filter up one directory and re-start Cubase. You should then see the emulated ports in Cubase. Enableemulated is in later versions.

Thanks! I moved the file up and restarted… Now forgive my ignorance, but what do I do now? I looked in the Device Setup section and don’t see anything obvious to change. I am still getting a delay on midi. Here is a screenshot of a basic midi track. it shows just a drumbeat on the halfnotes. when I solo this track and turn on the metronome, I would expect the drumbeat to be at the same time as the metronome but it is noticeably after the metronome.

on other issue I’m having, and I’m not sure if this is related but when I try to mixdown a wav file, the midi track is not on there. Is there something I need to do to get the midi to be in the mixdown?