midi issues

I have 3 MOTU Midi Express 128s. Running windows 8.1

I have installed all the drivers. The midi interfaces do not show up all the time in pc settings / devices. And sometimes they do show up and then they show up in Cubase but I cannot broadcast any midi data out of those ports even though they say they are there.

Is there a way to ping the midi ports? A command prompt maybe?

Also some times the midi interfaces let go while cubase is open and then I cannot quit or force quit / end task cubase. If I try to do a restart I eventually get a blue screen.

Anyone else having this issue and or have any advice?

When it does work it’s a great machine otherwise but I am trying to figure out how to train the machine. It’s fairly new.


Are the MOTU MIDI devices USB "class compliant’, i.e. can they be connected to Windows without MOTU drivers?

Are they connected to USB3 ports? If so, are the MOTU devices USB3 as well?

I do not think the interfaces are usb3 but they are connected to usb3 ports. I will try to uninstall the drivers and see what happens.

They show up in the device manager. the inputs are all active but only a few of the outputs are active. how can I switch and inactive midi port to an active one?


they are connected to a hub that is usb2. the hub is connected to a usb 3 port.

I have heard some people with the “Not enough resources” issue have turned off usb three in the bios and had good luck.

uninstalled the drivers and no luck at all. they did not even show up this time.

re-installing drivers now.

What does Motu Support say?

I am in touch with them and they are recommending a usb pcie card.

Hope you get it sorted, sounds like an enormous hassle.

After a reinstall of the drivers a lot more ports are showing up as available now but not all of them. Oddly even on the same interface I will have 2 ports that are “available” and the other ports are not…?

Is there no way to make these available after boot up of cubase? Or it is what it is?

thanks again

Theres your answer, your USB3 connection is the issue here. Get a PCIe USB 2.0 card and your problem will go away.

Do you have a USB2 port that you can test on?

I believe there is a limit to the midi ports. The erratic behavior may be due by the ports that are active thus reducing the remaining ports. So you have 24 ports and only 16 can be active at one time? Am I way off here? I apologize if I am.

In Cubase you must be careful not to deactivate the midi ports.

I did order a usb2 pcie card and will put that in asap. This morning I deactivated usb3 in the bios and that did not help either.

I will report back when I have the usb 2 card installed.

Thanks very much everyone. I have a large analogue synth collection that I cannot use until this is resolved. Thank god for innerclock and sync gen…

The usb 2 pcie card solved it.

for those buying a new pc… or switching from mac. always put a pcie or pci card in for usb2.

thanks everyone.