Midi Jitter during playback !!!

Hi guys,
I recently found out there is problem with midi playback inside my Cubase. Basically every time Cubase plays midi tracks differently. It seems this cause by midi jitter and it plays notes early or late by milliseconds. This is noticeable when I play mixture of audio and midi tracks.

I ran a test to make sure it’s a problem with midi playback and not the audio, so I created a “Groove Agent One” instrumental track and programmed a simple beat at 120 BPM. Then I exported the track as an audio and imported it back in and flipped the phase of the audio track. So in reality there shouldn’t be any sounds when I play them together. But I easily can hear drum parts are out of phase.
I’ve tested same thing in pro tools and everything seems to be fine. If jitter causes by my system why there is no problem in Pro tools?
This is a big issue for me when I have midis and audio tracks in a project. Or when I bounce Vst instruments as an audio and bring them back into the project.

This problem only occurs during the playback and not the final Audio mixdown. Also I’ve tested the same thing with Mbox2 and Presonus Firebox, so I guess this doesn’t cause by Audio Devices.

I’m running Cubase 5.5.2 and windows Xp sp3.

Any comments and help would be appreciated.

Thanks…

Are you sure you can do a null-test this way? The vsti needs more calculation than the wave eventually and maybe has some options for dynamic play (e.g multi layer samples, random pitch and volume etc.).
Did you try to do a null-test with several wave exports?

Are you sure you can do a null-test this way? The vsti needs more calculation than the wave eventually and maybe has some options for dynamic play (e.g multi layer samples, random pitch and volume etc.).

well I’m using single samples only, a Kick, a snare and a hat. no modulation what so ever.

Did you try to do a null-test with several wave exports?

Yes, the null-test works with several wave exports. thats why its only happening during playback.

If the output between a comparison of a VSTi and an export in Pro tools is null, I should stick with Pro tools because that’s the most accurate.
I think other users of C5 & C6 won’t get a null either when they compare a realtime VSTi against an export.

Well, This is a big issue if this happens in C5 & C6, since layering midi and audio tracks would create phasing problem during playback and mixing. also we can not use an instrumental track as a source of sidechaining.

Have you run this test on your system?

Yes, both C5 & C6, same result at 24bit 48khz.
Did the test with Battery and Groove agent, both same result. The random differences where mainly in the mid and higher frequency spectrum (1khz and up).
Without the nulltest I never would notice it, I think the variations in my test where smaller then a millisecond.

How was your results comparing to this one? (Please see the attachment)
Playback_01.zip (937 KB)

Nearly the same as yours.

I did also download your project file from the other threat.
The result of the 1st marker is the same as we noticed earlier (shifting).
When I duplicate your action the real time result stays is the same (shifting).

But when I mixdown your marker 1 part and my duplicate the result is interesting.
The mixdown of the marker 1 part has a few shifts in the mixdown (less then realtime playback though). The duplicated part however is null.

When I compare your output of the VST (MixDown) against my output of the VST the result is the same as the mixdown of the marker 1 part (few shifts).

So both our 32 bit XP systems with Cubase mixdown a VSTi in a slightly different way, I guess.

For me 1 or 2 samples on 44100 sampels per second isn’t a real biggie :wink:

But for what is worth, I also did a test with Studio One (Artist) and its instrument, Sample One. The result wasn’t exactly null (I needed to shift the exported wave -0.06ms to get it in phase) but unlike Cubase, the midi triggered audio was constant.

Thank you for testing it. You are right, the midi trigger in Cubase is not constant. I ran a internal midi test using “Maple virtual midi cable”. I created 16th note midi steps and record them back to another midi track, The results were different everytime.


Here is a screen shot
Midi Cubase.jpg

This is WAY too serious and needs attention from Steinberg.

Basicly, layering of drum / percussive sounds is impossible as long as this is not fixed. Major bummer.

Emulated ports or System Timestamp may solve the issue, depending.

Just did the same test. The timing on the MIDI playback is not even. The results I get are mostly silence with an occasional out of phase snare or kick coming out. Emulated ports and system timestamp did not help.

Just thought I’d share the output that I recorded:

http://dl.dropbox.com/u/32558357/c6_MIDI_timing_test.mp3

Simple drum pattern, all humanization turned off. First it’s just the MIDI playing, then for the second loop I un-muted the already exported track. This is using DFHS (the 2005 version). With Groove Agent One it’s almost ALL out of phase hits coming through with no silence. Does GAO have some kind of humanization functions built into it that offset the MIDI notes? If not then I have no idea why it seems like the timing would be plugin dependent (and if that were the case, wouldn’t a first party VST3 plugin like GAO be better synched with Cubase than something a third party released 6 years ago?)

Using BFD2 I get just about NO timing problem, maybe a random out of phase kick drum every 10 loops.