midi ['key'] editor doesn't follow cursor

the viewing field in the midi editor doesn’t follow the cursor, even when ‘link editors’ is set in user preferences.


  • create a span of midi notes lasting 30-40 bars.
  • in the main window [track editor], position the playback cursor near the end of the span.
  • open the midi editor.
  • send the cursor to time 0.
  • the cursor does move to time 0, but the editor window doesn’t follow it. in fact, it doesn’t move at all. all zoom actions still occur relative to current visual position when the editor was last opened. you have to grab the slider with the mouse and move the viewing field by hand.

the editor follows this same behaviour for any cursor movement, not just sending it to time 0. for example, if the viewing field is at the beginning of the song and you send the cursor to the end, the viewing field remains at the beginning of the song.

Did you turn on Auto-Scroll (Key default is ‘F’)?

you hit it on the nose. you know, i had it on , but i must’ve hit a key combo or something and turned it off accidentally. :unamused:

anyway, i’m pleased to report it’s working fine, my bad. :blush:

thx Mate :smiley: :smiley: