Midi Keyboard Activating Record

Cubase Elements 8 latest update

Casio CDP120 very straight 88 key piano no faders or knobs , works fine in Cubase but if I press keys in the highest octave say the highest C it starts to minimize the track view, If I press the D it scrolls through the Tracks and other piano keys activate recording and save . It has led to me accidentally overwriting tracks, its not a good situation.
I have all midi devices except the CASIO USB-MIDI and Microsoft GS Wavetable Synth turned off in the Midi Port setup . Its bizarre . If anyone can help to stop this it would be much appreciated .
Thanks

Ok
I solved the issue , but I will post the solution here just in case anyone else has the same problem. If you go to Devices -> Device Setup -> Remote Devices -> Makie Control make sure Midi Input & Midi output are not connected .
I remember a few months ago having a Korg Nano control hooked up , I cant remember why but for some reason I had to have the Mackie Control activated for the Nano control to work . I haven’t been using the Nano control for a while now but because I left the Mackie Control option still active it was conflicting with my generic Casio piano keyboard .
So if you are getting similar problems look at remote devices in Device setup , It solved my issue.
Cheers