Midi keyboard assignment...

Some times i forget to turn on my midi keyboard first before i launch Mac Cubase Elements 7.

When a project opens it tells me that the midi is not mapped which prompts me to turn on my midi keyboard.

When that happens of course all the midi tracks in the project show up as not connected whereby i “connect” them one track at a time.

Is there some quick way to connect all the midi tracks in the project to the midi keyboard all at once ?

Hi WTS,

select them all, press “Shift + Alt” and select your MIDI in one of them. Then all selected tracks will adopt the changes as well.

Regards

It sounds like you’re using a Mac (because MSwindows demands Cubase be restarted to recognise new midi ports…). But if you aren’t then this info isn’t relevant to you at all!

You could make use of the ability on a Mac to create virtual midi devices which sit between the hardware port and Cubase. The advantage here is that they are always available even if the hardware port is missing, and they connect back up automatically when the hardware appears, thus when you start Cubase it will connect to the virtual port, and when you switch on your keyboard the virtual port will connect and complete the circuit.

Some more info is available here: http://www.soundonsound.com/sos/nov08/articles/applenotes_1108.htm

Mike.

Luis Dongo,

Thanks.

Mike @ GargoyleStudio,

Thanks.

Yes, i have the “virtual” studio setup in Mac OS X

Actually your answer helped me understand why it is that i can turn on my keyboard AFTER launching Cubase and still be able to make the software “see”/connect to my keyboard.

And i never knew that in Billy Gates system you would have to turn on your keyboard first and then launch the software. Otherwise you are forced to re-launch the software. Wow, what a pain in the studio that can be especially if you are anxious to get a project going before the idea evaporated from your mind.