MIDI keyboard drum/perc. mappings are quite broken

Heyo all! Thanks in advance for the help.

Recently, I have been having issues playing the ‘drum set’ instruments on my MIDI keyboards (I have used a couple different ones with it whilst having this issue.) For some reason with an update a few weeks ago (prior to 4.1 which I am now running and still having the same problems), all of my drum/percussion mappings became very messed up. (Kick drum on F4, snare on C5, all but about 15 of the sounds just missing from the entire keyboard.)

At first, I just thought that an easy fix would be to go to Library>Percussion Mappings and reselect the correct one. But after trying all of them, nothing fixed the problem. I thought maybe it was something an update would fix, but no luck there either. I have searched the internet far and wide for answers but the few people I found with the same issue were able to fix it with perc. mappings.

So, any help would be appreciated. If attaching a file to see if it’s just a problem with my computer would be helpful, let me know and I can do that. (:


Other notes:

  • Using a Windows PC as my primary computer, but I have had the same problem using a Mac too.
  • Currently running the newest version of Dorico (

Unfortunately no project file was attached to your post, Logan, but I think the problem is most likely going to be with the settings on the Note input and editing page of Preferences, where the various options for percussion input from MIDI keyboard are located. Take a careful look at them.

1 Like

Thanks so much Daniel, that fixed it!

For anyone in the future that may stumble upon this thread, here’s what solved it:

  • Preferences>Note Input and Editing> Percussion Input
  • Make sure the “input onto kit or grid” toggle is set to “Use percussion map”