MIdi keyboard input stops with Dorico 3

While I’m in write mode, using my midi keyboard to input music, the midi just stops, I can hear the instrument fine but the green light doesn’t come on anymore and playing on the keyboard doesn’t input notes. I have to close Dorico down and restart it, and then everything works again for a few minutes until the midi cuts out again. Anyone else having this problem?

I have a iMac running 10.14.6 with a Komplete keyboard and Komplete Audio 6

I can’t say I’ve had this problem, but now that Dorico theoretically supports hot-swapping, have you tried unplugging the midi keyboard and plugging it back in, rather than restarting Dorico?

We have had a few reports of this problem but so far been unable to pin down the circumstances under which it occurs. If you disconnect and then reconnect the keyboard, rather than quitting and restarting Dorico, does that allow it to come back to life?

Yes I tried unplugging the keyboard, and also the audio card, but nothing worked. I’m just starting to work again, I’ll try to see if I can figure out what makes it happen and if I can I’ll write back.

I tried to follow what makes this happen, but nothing out of the ordinary caused it. It did better today, but I\ll keep following it.

I’ve had the same problem here. My keyboard would trigger NotePerformer sounds but no green light nor possibility to input notes, until a restart. I’m using MIDI capabilities of the UR 242 (and when I had the issue, that port would still appear as selected in the MIDI I/O preference panel), if that helps.

If you experience this problem please make a note of the time it seemed to stop responding and then create a diagnostic report to upload here.

Slightly off topic perhaps, but regarding disconnecting/reconnecting:

Viewing the full score: disconnecting/reconnecting my akai LPK25 Dorico freezes.
Viewing a part layout, only one instrument: disconnecting/reconnecting worked like a charm.

(Dorico 3, OSX High Sierra)

(Apologies for starting a new thread on this topic, moving my discussion here).
I have this problem also. I’ve tried unplugging/replugging my midi keyboard in, which doesn’t help (it’s a USB interface). Restarting Dorico 3 makes it work again for awhile. Attached is my diagnostic report which is the next step after the green light stopped working.
Dorico Diagnostics.zip (382 KB)

Next time this occurs, please also do a couple of further tests after step-time input stops working: can you still hear the notes echoed even though no notes are input? If you attempt real-time input, does that work?

OK, it just happened again. The short answer to your questions are Yes and No.

I was successfully entering notes, then single-clicked another instrument so I could listen to myself improvise on the midi keyboard (without entering notes). The notes continue to sound, but the green light stopped working.

I don’t use midi recording, so had to review the video… here’s what happened.

I added a new flow. Then Edit → Preferences → Play → Midi Input Devices. The Xkey is checked. Looks good.
Set 4/4 time and added 24 more bars.
Selected the first rest and pressed Ctrl R.
It beeps and after a measure or two I start playing the midi keyboard. I can hear the notes playing.
Clicked on the red Record button to stop recording.
No notes were entered – uh oh.
Got the diagnostics file (attached).
Closed Dorico 3 completely.

Restarted Dorico 3 and opened the same file. The midi was still plugged in.
Repeated the steps to record which worked great (so I now know how to record!)

I kept playing random notes on several instruments, a lot of them, and it’s working ok for some reason… will report back if it doesn’t.
Dorico Diagnostics.zip (356 KB)

p.s. I’ve been using Dorico 2.2 to get notes on the page… seems to work fine. Fortunately I’m in the early stages and have not been using D3 features yet.

p.p.s. It lasted quite a while acting ok, but finally stopped inputting notes.

Please enjoy raw console log from the span of one minute around when I pressed key on a midi keyboard to find out that it does not play. If the bug happens in the background before this time I could not siphon through the logs yet, but I have found numerous lines regarding Dorico3, VST engine etc. f.eg
VSTAudioEngine3 domain com.apple.iokituser.hid.iohidpostevent is NOT on the whitelist AND device is NOT internal. Message will be dropped
Dorico MIDI fail.zip (48.2 KB)