midi keyboard not recognized

My Studiologic wmk 188 midi keyboard is not recognized in Dorico.
It works fine in Cubase and Sibelius.
Any thoughts ?
Mads

Is the keyboard definitely connected when Dorico starts? If you’re also running other applications that might use the MIDI keyboard, then make sure they’re not running before you start Dorico.

yes it is. Connected the keyboard, restarted the computer - have only Dorico running = no midi.
Exit Dorico, load Cubase or Sibelius = midi.
Mads

Can you find the folder C:\Users\YOUR_USERNAME\AppData\Roaming\Steinberg\VSTAudioEngine_64, zip it up, and attach it here? I think somewhere inside its contents we will see what MIDI devices are being detected on your computer.

Seems to be the same issue as with my Behringer keyboard. Have a look at this thread: https://www.steinberg.net/forums/viewtopic.php?f=246&t=104141

Thomas

Here you are :slight_smile:
Mads

VSTAudioEngine_64.zip (910 KB)

Hi Mads,
thanks for uploading. Looking at the files, true, your Studiologic doesn’t get listed, only the MIDI port of your Fireface. As to why that is, I don’t know at all at this moment. It is so weird, because Cubase recognizes it, so the driver is installed correctly. Also, Dorico’s audio engine inherited nearly everything from Cubase’s audio engine, including the handling and opening of MIDI ports. So I have currently no clue as to why this happens to your keyboard. Well, we certainly have to have a deeper look at this.
Additionally, could you also zip up the log files that you can find in C:\Users<yourname>\AppData\Local\Temp\VSTAudioEngine and also attach here?

In the meantime, could you workaround this issue by connecting your Studiologic to your Fireface MIDI in? Would that be acceptable for the moment? Sure we have to address your issue, but can’t estimate or promise anything when it will be fixed.

Cheers,
Ulf

hi Ulf,
The Studiologic is already attached directly to Fireface Midi in. It transmits on channel 1.
Here are the logs.
Good hunting :slight_smile:
Mads

VSTAudioEngine.zip (19.9 KB)

Same issue here, I have 2 keyboards connect to my PC (windows 10 64BIT) Korg Kronos 2 (via USA) and Korg R3 (via Midi - 2X2 converter)
Dorico won’t recognize any of them :\

Just purchased an inexpensive but serviceable small midi keyboard: Nektar GX49.

It works just fine with Dorico.

I’m running a late 2015 13" retina Macbook Pro, OS X 10.12.1 (Sierra)

Hi Mads,
if your keyboard is already directly connected to your Fireface, then it is an even bigger mystery. Because each log files shows, that the Fireface MIDI port did get recognized by the audio engine and that MIDI streaming got enabled. So I see no reason, why it shouldn’t work. It must…
Ehm, please don’t get insulted, if my question sounds too trivial, but are you aware of how MIDI input works in Dorico? Sorry, just asking, I’m not saying that you are too stupid or so. It’s just because, from all what I heard and got from you, I see no reason why it shouldn’t work.
So, the MIDI input to Dorico just works when you double click somewhere on a stave. Then from that point on notes will get inserted whenever you hit a key on the MIDI keyboard. But you won’t hear any sound at that stage, because the MIDI data will not get rerouted to the audio engine. This is a feature that will come in a future update of Dorico. You will only hear sound when actually starting the playback. MIDI input is so to say just silent.
So with this in mind, could you please start a new single player project, then in Write mode double click on the stave and start playing some keys on your keyboard, will the entered notes get added to the score? In any case, please save that project and attach it here, because in the project data I also might find some clues. Please note, the forum won’t allow to attach Dorico project files directly, you have to first zip it up first and then attach.

Thanks for your collaboration
Ulf

No offence taken. I didn’t know that I had to tick “note input” to get it to work and choose a note to make “note input” active. Where is that stated in the help pages or videos ?
Anyway - this post from another thread solved it and midi input works now + I can hear what I input :slight_smile:

Unread postby gideonleong88 » 23 Oct 2016 17:56

Hi Thomas,
I think you might need to go the menu , Write mode, and tick “Note Input” or double-click on the first rest where you see the caret blinking and start playing your midi keyboard.
I was confused like you as well, as to why my MIDI keyboard “didn’t” work.

Hey Mads, I’m so glad that it works now for you.

Cheers
Ulf

so am I :slight_smile:
This is one of those things - among a lot of others questions here on the forum - that a proper manual would have saved both you and us from a lot of useless time and frustrations.
You have the worlds best manualwriter among you - let him spend more time on this !
Mads

This is now mentioned inthe FAQ

Good!
Unless there’s a specific reason not to I suggest that this option is ON by default.
MAds