MIDI keyboard not showing up under MIDI port setup

HI all. I’m hoping somebody can help with this frustrating issue I’m having.

I use AKAI MPK midi keyboard, it’s been working fine for months and I used it just last night too.
And then this afternoon I brought it and my windows computer to work and when I started Cubase I found it did not produce any sound.
I tried restarting cubase and then rebooting the computer while usb was still plugged in, and then I tried moving it to a different port and
rebooting computer, still nothing.

The midi is not only making any sound but I can’t record with it either so I went to Device Setup -> MIDI port setup and found out that my
midi is not listed under it. The only thing I see is
Windows MIDI OUT Microsoft GS Wavelength Synth Microsoft GS Wavelength Synth x inactive (In ‘All MIDI Inputs’ is empty)
I googled for hours but could not find how to bring it back.

What do I do?? Any advice is much appreciated.
Please help!! Thank you.

Hi and welcome,

MIDI Keyboard doesn’t produce any sound, it just sends MIDI data. :wink:

If you can’t see it in the MIDI Port Setup, it means the driver is missing. Try to install the driver again. Make sure you can see the device on the system level.