Midi Keyboard not working only with Cubase...

I really need help with this… Im new to Cubase and Im going crazy. How can my midi keyboard be automatically recognized and be working one minute and just closing a project and opening a next one make it not work. Since yesterday I’ve been trying to figure this out. I opened 3 other DAWs and my keyboard and my padkontrol works fine. I see a green bar jumping on my transport in Cubase so its receiving signal but nothing is coming out. Also before that happened I started a project with midi drums and a midi synth part and even though they both had information starting at the same time, when I hit play I would only hear the drums for about a bar before the synth kick in, and there were no held notes so its not like the first part of the note was not recognized and it had to wait until that held note was done and it received the beginning of another midi note, they were all stacc notes. I am running Cubase 7 can someone please help me. And one more thing, I want the transport window to stay open but every time I open the mixer it goes away… Is there a way to fix that? Its kind of distracting to have to keep bringing it back up every time I open the mixer.

If you want help I think you need to provide more information.

This MIDI keyboard for example, does it have a name?

i uninstalled Cubase and started over and everything works… for now. but about the transport, how do I get it to stop going away every time a window opens?

you were asked a question about your keyboard for future reference so if you can’t be bothered to name it why should someone help you ?

i can confirm the problem.

  1. Start Cubase 7
  2. Create VST Instrument track with Halion Sonic SE
  3. Play on the MIDI Keyboard --> nothing
  4. play on Halion Sonic SE virtual Keyboard --> it works

With Cubase 6.5 no problems

Deleting the preference folder C:\Users\your_username\AppData\Roaming\Steinberg\Cubase 7_64 does solve the problem, but I don’t want to reenter all settings I changed within the last weeks and months. I don’t get paid for that…

it’s the defaults.xml in the C:\Users[Username]\AppData\Roaming\Steinberg\Cubase 7_64 screwed up by,sarcastically expressed, who knows…Sorry but there is no other way to express my discontent and I know that it is the tone that makes the music. But I like Brecht/Weill…

Fortunately, I saved earlier default settings, thus in the settings dialogue you can load the old settings.
Restart Cubase 7 and MIDI works again.

For those who did not save their settings in a file the Steinberg coders and/or support might find the faulty part in the default.xml file if they can catch a breath while coding out the other faulty parts…

I go on working and hope not being annoyed by such kids illnesses.

Bye Bye :unamused: DIY DIY DIY DIY DIY