Midi keyboard notes trigger switch between instrument tracks

When playing at the high register of my midi keyboard, keys between C6-G6 don’t send midi notes to the selected instrument. Instead, they switch the selection from that instrument to different ones. Any idea what might be going on?

Using Cubase Pro 13.0.30

That sounds like they are Keyswitches used by your VSTi to change articulations. The Instrument’s documentation or User Interface should indicate the specifics. In Cubase Expression Maps are used to make using Keyswitches & other articulation methods easier.

Google MIDI Keyswitches

Sorry, maybe I wasn’t clear in the original post, I meant to say they are switching around which Instrument/MIDI track is selected in the project. Say that I have selected the Harp in the screenshot below, then I will press one of those keys and the celeste will get selected instead, and then if I press it again, the Glockenspiel, and so on and so forth.
image

This is not (at least normal, as far as I am aware) key-switch behaviour, especially since it is happening in the playable range of all the instruments I am talking about.

A little more should be said
How are your midi tracks connected?

So it sounds like MIDI Notes are causing Cubase commands to be executed. There are two mechanisms that can do this. The newest one is the MIDI Remote while the older is the Generic Remote. It is more likely the Generic Remote causing the problem since it is easier to accidentally run, where the MIDI Remote has to be actively setup.

You can find the Generic Remote in Studio Settings. Disconnecting any MIDI Inputs to it will turn it off.

Or even an MCU based controller…

Notes C6 and C#6 in Cubase I think correspond to C7 and C#7 in a more global definition. That is MIDI Note numbers 96 and 97 which are responsible for up and down movements on a controller of this type.

@JKns check also if you have your keyboard’s port accidentally mapped to a Mackie (a normal miss is to set the ALL MIDI as a midi input).

It was MIDI Remote after all, thanks!

For anyone with the same issue: It could be seen under the ‘Usage’ column of the first ARIUS (my keyboard) instance. I went to MIDI Remote on the left column, clicked ‘open MIDI remote manager’ and deleted the selected controller.