Midi keyboard working but not showing in "Play - Midi Input Devices" window

A strange one this. I’m running Dorico 5-SE as a proof of concept exercise for a Male Voice Choir who wishes to cut over from Sibelious software.

Equipment being used

  • Tower PC loaded with a fresh copy of Win10 specifically for this task. Other than standard software only Dorico 5SE and something called “MidiEditor” installed
  • Midi Interface - Lekato LUM-03 USB-C
  • Midi Device - Yamaha Clavinova CLP545R Electric Piano

Everything seems to work but nothing appears in the “Preferences - Play - Midi Input Devices” panel. If I fire up the MidiEditor software that does show all 16 channels from the Clavinova.

Any ideas?

Dorico Diagnostics.zip (269.7 KB)

Welcome to the forum, @phaz. Can you check whether the WinRT-MIDI option is enabled in the Advanced Options section of the Play page of Preferences, and if so, try disabling it?

Checked the advanced settings - the only switch checked is Enable ASIO-Guard.

The “Enable WinRT Midi” switch is DISABLED.

Can I just check that you’ve noted my comment that Dorico works - this seems to be just a display problem.


Your diagnostics suggest that you should see an input device called USB MIDI Interface appear in the list of input devices on the Play page of Preferences.

Hi Daniel,
I’ll move my “Sand Box” PC back to the piano and have a look while it’s connected up.

Btw. It will help you to know that we can talk “shop”. I have 25yr+ in the IT fix it business in both Software and Hardware. I was used to flying solo at EMEA level for IBM.

I’ll do the PD and be right back.


You shouldn’t need to move the PC back to the piano: assuming the Clavinova is connected via your MIDI interface, you will in any case only see the USB MIDI interface listed in Dorico, not the Clavinova, even when it’s hooked up. There’s no way for Dorico to know what’s on the other side of the MIDI interface, so it’ll only “see” the interface.

Hi Daniel,
I’m running between two rooms so easier to move it back now so that it’s all hooked up just in case you need to dig deeper.

In answer to your question - Yes, the "USB Midi Interface " switch is shown and is ticked. It’s the pane under that which is BLANK.

If I try to record notes from the keyboard it all works as designed. The Green light flashes and when I hit “stop recording” and the black dots (0: appear on the staves.


You would only see the Clavinova appear in that list if you connect its own USB port directly to your computer, but from your description (and from your diagnostics, which do not show any sign of the Clavinova itself being connected to your computer), it sounds as if you are connecting the Clavinova via the Lekato LUM-03 USB-C MIDI interface, in which case that’s the only device you’ll see listed in Dorico.

In short, it sounds like everything is just as it should be.

Hi Daniel,
For clarity and for others that will read this thread in the future …

I can not see (or I’ve missed it) anything in the Dorico Play page that tells me that I have my Lekato Midi Interface adapter connected. In the pane that is blank I was expecting to see “Channels 0 thru 15” listed as in the MidiEditor software when I run that and as is also indicated to be the case on your excellent YouTube tutorials. I get it if Dorico can’t tell me the make and model of my piano on the downstream part of the Midi interface but I would expect Dorico to show that something is attached and talking to it.

Are you saying that this pane should always be blank under these circumstances?
(I can pull a screen shot if that would help.)


By all means do attach a screenshot. It sounds from your previous description as if the list is not blank, because USB MIDI Interface appears, and is activated. That’s all you should see.

Hi Daniel,
If this screen shot is correct, what is the process to put in a change request to get Dorico to show somewhere that a USB Midi Interface device is connected.

I’ve lost hours on this project I’m on trying multiple things in an attempt to get something to appear in this blank box (as shown in the tutorials) and failing. I only discovered that Dorico was actually working through pure chance which then prompted me to report this issue.

Let’s hope something positive in the way of product development comes out of this thread.

Thank you for your excellent service.


That box isn’t blank, it’s a list view showing a single entry. The entry consists of a checkbox and a label. The label shows the name of the MIDI port. The checkbox shows whether the MIDI device corresponding to that row in the list is enabled.

Your Lekato LUM-03 USB-C MIDI interface evidently presents a device called USB MIDI Interface.

I can see why you might think that this is a blank list that has a header that says “USB MIDI devices”, but it’s not: it’s a list of all MIDI devices detected on your system, and the only MIDI device on your system is called USB MIDI Interface, so it’s the only thing that appears in the list.

Beer time for Daniel on phaz… :wink:

1 Like


And so the “light” finally comes on. :joy: Now it all makes sense.

I was reading it as a switch to enable/disable generic USB Midi Interfaces. :man_facepalming:

I don’t mind being a complete idiot if it helps others. This wasn’t the first time and I’m sure it won’t be the last.

Thanks once again for your time and proving that a picture’s worth a 1000 words.

I’ll flag this as solutioned.


For sure. Have two beers in fact - and large ones at that.

Would you mind tagging Daniel’s answer as Solution ? It would help people with the same problem without having to read the whole thread :wink:

1 Like

(I thought I already had if I’m honest)


1 Like