MIDI lanes: inconsistent, sometimes two are selected at once

Hi - anyone know why this might be happening to me?

(My MIDI settings: “New Parts”, and “Stacked”, i.e. for single track active at once.)

About half the time things work as one would expect: I’ve got my MIDI lanes showing, and one is appropriately colored with the track color, and is the lane that plays. The others are grayed out and are muted. I can click on a grayed-out muted track and it swaps out with the active track. Similarly, if I click on an active track it becomes gray and muted, and another track becomes active.

1) But - a lot of the time when my MIDI lanes are showing there are TWO active tracks simultaneously, and they both play back simultaneously.

The weird thing is, when that happens - if I randomly click on various lanes for an infinite period of time :slight_smile: it will revert back to only one lane being active at a time.

2. Also - Sometimes when I cycle record, the behavior is “Mix” instead of “Stacked” - what I’ll sometimes see is when I overdub, I hear the previous lane’s take while I’m recording the current lane.

Is anyone else having problems like this? Is there another setting I need to know about?



You can use multiple MIDI lanes at once (not Audio). This is expected behavior.

Thank you, Martin!

I was not expecting that behavior with the MIDI settings I chose. Can you tell me please which settings I should choose instead? I would like to:

  1. Cycle record in MIDI so that I only hear the current lane … previous lanes are muted out.
  2. When editing, have only one active lane at a time … but sometimes two are active, and it’s not clear to me what I need to do to have all muted but one (except, as mentioned above, randomly clicking lane after lane after lane until somehow/for some reason it seems that only one lane becomes active, as desired.

Thanks for any more thoughts!


  1. Use MIDI Cycle Record Mode: Stacked.
  2. Use Comp Tool to select, which Lane should be the active one.

Thank you, Martin!

I mentioned in OP I am using Stacked, and I should say here I am using comp tool.

Nevertheless, I am getting the behavior I described :frowning: .

Do you use Re-Record? Could you post a screenshot of your setup, please? Maybe we will see something…

Yes, thx, which screen shot (which setup) are you referring to?


Don’t know exactly, because I don’t know where the issue could be. MIDI and Record Setup, please.

I’m also experiencing this issue. I choose stacked because I want new parts to be created but “only the last one to be played back”. This is NOT what happens (but like you say it is inconsistent). For me only the first few notes of the rogue lane. So when I go to record a new lane, even though only the newest (blank) lane is selected via the comp tool, the previous (unselected by comp tool) lane’s first few notes will play.

So I just bought Cubase 12 Pro… and the VERY same thing is happening to me. I am guessing 5+ years later this must be some sort of feature/option… but for the life of me I don’t know why it happens. Hopefully someone sees this and has an answer.

Basically like others, I am in stacked mode, new mode. I record a few lanes. That seems to work fine the very first time I start (clean track).

Where this behavior occurs for me… is if after having some lanes… I select one of the lanes, then hit Record. I expect that a NEW lane is created… and I only hear that new lane. But instead, the previously selected track ALSO stays selected and plays. OK… that’s cool… if it’s supposed to do that… great. But… it’s not typical selection behavior. I can’t seem to UNselect the tracks either. Or… well… I can if I use the COMP tool… while recording new takes/lanes… but that seems odd… you would use comp tool after done recording. I cant find any tutorials or details in docs on this particular issue either. Almost seems like an unknown/undocumented feature… but if a noob like me can easily recreate it and not on purpose… it just happens… I have to believe a LOT more people have done this too. When it happens, I would expect the left side of the track (e.g. left to the actual notes… where top track has mute/etc on it) would highlight… and allow unselection to avoid any accidentally selected (or whatever this ‘feature’ is called) to be unselected.

I could provide a screen recording of this if that would be helpful.

1 Like