Midi lanes : is this correct?

I’m new to Cubase 9 and will recording some midi events on one track (to try something). I’m using Lanes, but all midi are playing the same time instead off the last lane or the lane I select.
What is wrong?

Look at midi recording modes - there are a lot of options how to mute as takes etc.

If you have lower toolbar visible - it’s on the far left - both for midi and audio.