MIDI Latency in Dorico 3.5

I’m getting latency in D3.5 which is significant enough to be a problem. My keyboard is connected through USB to my PC and there are no issues with my DAW only with Dorico.
I’ve tried messing around with the latency settings in Dorico but no matter how much the delay I enter, the sound I hear is still lagging behind the score I’m playing to. Any ideas?

Can you tell us a bit more about your setup, Nick? What kind of audio hardware do you have? What buffer size settings are you using in Edit > Device Setup? What MIDI latency values have you tried in Preferences?

Focusrite Clarett 2Pre USB (ASIO latency reported as 2128)
Buffer size in Dorico - 512

I’ve tried -1000 & +1000 and a few random numbers in between. Currently on +1000 (the maximum allowed).

I’m monitoring direct from the Clarett interface, and keyboard is USB’d direct to the PC (which works fine in my DAW).

I’m playing piano from HALion Sonic SE to a score in D3.5

+1000 seems a bit high and is nearly enough, any suggestions about the lag, have I set something up wrong?

Larger buffer increases latency. Try making it smaller.

1 Like

Firstly, to minimise latency, the ASIO buffer size must be set to something small, typically 128-512 samples (any lower than this and it increases CPU load and increases the risk of dropouts). You also need to be using the Focusrite ASIO driver and not the Generic Low Latency Driver.

The setting in Preferences > Play > MIDI input latency compensation has no effect on how quickly incoming MIDI notes are played back. This actually applies an adjustment when trying to work out the musical time of the recorded notes. It’s used if you find that the notes in the score are always a bit early or late. See this earlier post for some tips in setting that: Tips for MIDI recording

2 Likes

Thanks for that info. As you say, it’s actually an audio delay and not a MIDI problem as I thought.

ASIO buffer adjust size solved it. Thanks to all.