Midi latency with large buffers.

Hi folks,

I just switched from an M-audio to a Casio (px150) controller keyboard and I immediately noticed big problems with latency at high buffer settings.

Just to be clear what I mean, I mean that not only is there a delay between what I play and the note I hear - that’s normal - but there’s also a delay in the printed midi info - that’s not normal.

I like to keep the buffer set to maximum when I’m tracking piano and just use the built-in (no-latency, obv) sound from my Casio and just play to the click, but now my recorded notes are consistently behind, more than a 32nd note in some cases. Needly to say that lag decreases greatly when the buffer is set low.

I’ve tried using Constrain Delay Compensation with no luck. Does anybody have any other suggestions that would let me use what is otherwise a pretty decent keyboard?

OSX 10.9.5, Cubase 7.5.4

I’m confused.

Why to you want a high buffer setting?

Wouldn’t you want to track with the lowest buffer setting?

I like to listen through the software and use plug ins real time. You need about 4ms latency for that.

Have you changed your interface? That’s usually the what stops you from lowering the latency to your liking, as well as the computer.

I’ve got an old computer and Cubase is a resource hog, so to minimize all kinds of problems I keep the buffer high and just use the monitoring from my RME card so I (usually) don’t have to worry about latency.

Haven’t changed anything except my keyboard, and RME drivers are generally rock-solid.

Are you using USB or midi from keyboard to computer ?

USB - the Casio doesn’t have a midi out.

El bump!