MIDI Learn Command to Stop Recording

Ok, so this should be simple, but in the key command window there’s no option to stop recording. I tried simply ‘Stop’ but that didn’t work. I’ve got ‘Play’ working on my S88 MK2 (Native Instruments) and ‘Stop’ (playing), and ‘Record’, but can’t figure out how to get recording to stop using the provided key commands. I even tried pressing ‘Record’ again thinking maybe it works like a toggle, but no cigar. Anyone?

The Play > Stop Recording command is the one you’re after, which has a default assignment of 0 on the numeric keypad (if your keyboard has one).

1 Like

That option is not available for me.

There isn’t a specific Stop Recording function here, either. The Play > Stop Playback function seems to work, though, even if I’m recording.

1 Like

I believe I tried that option and it did not work for me. But I will try it again to reconfirm.

Sorry, I mistyped: it is indeed Stop Playback.

Ok, so I still can’t figure out a way to program the ‘Stop’ button to stop recording, nor can I find a way to program it to stop playback. For reference, I’m using Windows 10 and my MIDI controller is a Native Instruments Komplete Kontrol S88 Mk2.

Play (for me this works; after which I can press the ‘Play’ button on my controller to start playback).

  1. Go to Edit / Preferences / Key Commands / Play / Start or Stop Playback / Start of Project
  2. Click the MIDI learn button in the ‘MIDI Learn’ section
  3. Click the ‘Add MIDI Command’ button
  4. Click the ‘Apply’ button
  5. Click the ‘Close’ button

Stop recording (this is the action I want to perform, and yes I realize this exact verbiage is not an option under ‘Play’ under ‘Key Commands’). No, this did not work for me.

  1. Go to Edit / Preferences / Key Commands / Play / Stop Playback
  2. Click the MIDI learn button in the ‘MIDI Learn’ section
  3. Click the ‘Add MIDI Command’ button
  4. Click the ‘Apply’ button
  5. Click the ‘Close’ button

After performing the above two sequences of steps (one worked; the other did not) here’s what I have to do on my controller.

  1. To ‘Play’, I click the ‘Play’ button (after performing the above steps to program the ‘Play’ button).
  2. To stop playing, I simply click ‘Play’ again (not very intuitive but it works for me). I discovered this by accident. Of course, I can always click the soft stop button in the GUI, but this defeats the effort here, that is, to program my controller buttons to perform the actions.
  3. To ‘Record’, I click the ‘Record’ button (I didn’t list the steps for it, but it’s very straight forward).
  4. To stop recording, I have to manually click the soft stop button in the upper right corner of the GUI in Write mode. Nothing I tried with any of the MIDI Learn options/Key Commands worked to stop recording. And pressing the ‘Record’ button again didn’t work like it did for the Play button on my controller.

So, in summary, the only two actions that I’ve successfully programmed for my controller keyboard are ‘Play’ (just to start playback) and ‘Record’ (just to start recording). Programming the ‘Stop’ button appears to be problematic for my controller keyboard. Lest you think that my ‘Stop’ button on my controller is defective, it does work with my Presonus Studio One DAW software.

I should mention when I tried to program the ‘Stop’ button on my controller, when I clicked it while MIDI Learn was active, it always shows as ‘NOTEON93’, which doesn’t look very promising for a stop action. I would have expected something like ‘NOTEOFF…’. or ‘ALLNOTESOFF’…

What am I doing wrong?

I suspect you’re not doing anything wrong, and that it’s not currently possible to stop recording by playing a MIDI note, because Dorico isn’t “listening” to MIDI notes to try to pick out commands while you’re recording. I’ll talk to my colleague Paul about this at some point to see what it might take to make this possible.

That sounds good. As big as Native Instruments and Steinberg are in the industry, it’s shocking to me that Dorico doesn’t work with my ‘Stop’ button on my S88 MK2. I’m sure there’s a simple solution, maybe just a tweak to the protocols in the software?

Ok, tonight (early early this morning, 26 Aug 2021), I guess I waved my Harry Potter wand (“Episkey” spell) just right and got the right combination of settings to get the MIDI Learn to work for the ‘Stop’ button on my S88 Mk2. I’ve summarized the settings below. This works; I’ve now got ‘Play’, ‘Record’, and ‘Stop’ buttons all working. Here’s what I did to get all three buttons to work (I’ve summarized previously what I did for ‘Play’ and ‘Record’, so I’m only covering ‘Stop’ below).

Edit / Preferences / Play
  Recording Section
    Enable MIDI Input (checked)
    Enable MIDI Thru (checked)
  MIDI Input Devices Button
    Komplete Control - 1 (checked)
    Komplete Control Ext - 1 (NOT checked).
    Komplete Kontrol DAW - 1 (checked)
Edit / Preferences / Key Commands
  Stop Playback
    1) Click 'MIDI Learn' soft button
    2) Press 'Stop' button on controller
    3) Click 'Add MIDI Command' soft button
    4) Click 'Apply'
    5) Click 'Close'`

Your previous steps look like this. Are these steps complete? Did you really not press a single button on your MIDI keyboard while Dorico’s Preferences dialog was open?

Step 2.5 would be to press the button on the controller… but other than that the instructions are correct. It was late/early and I was running low on sleep. But the instructions I gave directly above for adding the ‘Stop’ button functionality are complete and correct.