MIDI Line Input Issue

Mac OS10.9.5, Cubase Artist 7, Komplete Audio6 Soundcard, BFD3

Hi there,

Trying to warm up the old studio again after much time away and have forgotten a few things :slight_smile:

Main bugbear currently is that I am trying to put a MIDI drum track down at the same time as playing on top with a guitar. For some reason I cannot monitor both my Line 2 input (which my guitar is on) and my line 3/4 (my MIDI drums) at the same time. This means that when I am recording or playing back I can only either hear my guitar or my drums but never both together. This obviously makes it hard to record anything in time… how do I either make it so I can hear both lines at the same time or put both the drums and the guitar playing through the same input simultaneously?

Also, and I appreciate this is probably more of a BFD forum question but just asking, I have dragged and dropped my drum groove from the BFD library in to the MIDI track in Cubase, however for some reason reason when I hit record there are two grooves playing simultaneously. One seems to be the groove that I have dropped in to Cubase and another seems to be some random one looping around inside of the BFD player. I have to manually turn off the loop inside the BFD player every time I hit record in order to stop it kicking off again. Not sure why. Any suggestions much appreciated.

Thanks!

As regards the Loop, just switch to “Grv Off” here
Groove Off.jpg
Not sure what you are referring to, by “Line 2” and “Line 3/4”. Are these physical ports from your audio device (in which case, why is BFD3 coming in from there? :confused: ). Are you talking about MIDI drums being played live (and wanting to be recorded), or a MIDI track already containing the data?
Anyways, it sounds like you either have something in Solo, or (depending upon answers to the above) only one of the two tracks record/monitor enabled at a time.
Sorry to be vague… (but so were you :stuck_out_tongue: )

Hi,

Yes i am referring to what I can hear through the monitor port on my external sound card. Either I can hear my guitar when it is switched to line 1/2 or I can hear the drums on 3/4.

I’m talking about MIDI drums where I have taken a groove track from BFD3 and then dragged and dropped the loop into a MIDI track on Cubase Artist 7.

Neither track is marked as solo. Both have the monitor enabled.

Hope this clarifies!

I don’t know the Komplete Audio6 Soundcard, but I am suspecting that this is happening because of the way you are using it for monitoring.(I have just downloaded the manual :wink: )
Are my following assumptions correct?..
Audio is passing between your computer and the Soundcard via USB?
From quick reading (be aware, I could be so far off the mark here :wink: ), I think you need to switch if Direct Monitoring completely, on the audio interface, and let Cubase take care of it (I am of course presuming that you do have the Soundcard set as the Audio interface for Cubase?)
Just let me know if this solves it for you, or makes it completely inaudible! :slight_smile:

Yes audio is passing between my computer the soundcard via USB.

I couldn’t seem to get any noticeable changes to the problem by hitting any of the relevant buttons on the from of my KA6 module (i.e. Monitor ON, Monitor MONO etc), nor any of the other buttons.

However, having worked on this on my own in the intervening time and started a new blank project, deleted all the old VST connections and set up new ones, I seem to be able to hear both the guitar and the BFD3 at the same time… the only problem is that for some reason I can’t seem to play the drum groove that I have dragged and dropped into the track. Instead I have to play the groove that BFD has itself selected. Not sure how to amend this?

Oh and, annoyingly (this always happens), having closed the BFD screen down I can’t seem to get it back up! Normally I would go to the small icon on the left hand side that looks like three long window panes/ vertical lines and click on it but for some reason this doesn’t always work to retrieve the BFD screen. Any suggestions on a fix for this appreciated!!

Are you certain that the MIDI track is routed to the BFD Instrument?

Oh and, annoyingly (this always happens), having closed the BFD screen down I can’t seem to get it back up! Normally I would go to the small icon on the left hand side that looks like three long window panes/ vertical lines and click on it but for some reason this doesn’t always work to retrieve the BFD screen. Any suggestions on a fix for this appreciated!!

This would indeed be the case if the MIDI track weren’t routed to the BFD.
(but I suppose you are going to tell us that it is routed to the BFD? :wink: )
BFD.jpg

Sorry, bedtime over here in Hong Kong :slight_smile:

OK, so you’re not going to be particularly happy with me. For some reason the file I was having problems with isn’t here any more (the audio files I made are but the actual recording template isn’t) so I can’t go back to the exact example I was working on last night and work through the problem with you. I guess I didn’t save properly when I closed down last night - sorry! That said, on setting up now I have a similar MIDI problem that is not answered by your presumed solution and presumably this must all be related in one way or another.

Currently I have an audio track running fine with my guitar going through it as normal. On the MIDI side I also have BFD set up as a VST plugin. I have drums selected and I can play and hear them as well as select grooves from within BFD. I have selected a MIDI track and on it I have ‘All MIDI’ selected as the input and ‘Komplete Audio 6’ selected as the output. Joyfully, I can hear both my guitar AND my drums (from within BFD) at the same time. However, still I cannot hear the drum play within Cubase. This is in spite of being able to see the drum track spike when I hit play/ record.

What does seem peculiar however, and I don’t know if this is related, is that in my inputs list it has ‘1 - BFD 3 - Midi Output’ as an option and in my outputs list it has ‘1 - BFD3 - Midi In’… that seems nonsensical to me.

Again, sorry for the roundabout start stop nature of resolving this issue that I am having. I promise I won’t turn off the computer again until this is resolved :slight_smile:

OK, so let’s get a clear picture of what is working, and what isn’t :slight_smile:
As per your last post, is the only problem now, that you can’t hear BFD playing (but you can see audio activity on the mixer channel?)
Btw, with BFD, are you getting the notes into there, just by loading its grooves, or are you (also?) playing into it via an external MIDI keyboard?
You mention something, that begs me to ask another question…

Are you using an Instrument track, or a “regular” MIDI track? (not a problem in itself… maybe more on that later, but let’s keep this as simple as possible :wink: ). To confirm this, can you tell me what the icon on the track looks like…
Like this (MIDI track… three horizontal “lines”)?..
MIDI.jpg
Or like this (Instrument track… like a “keyboard”)?..
Instrument.jpg
In any case, this seems wrong to me…

The output field (in the Inspector) should show “BFD3” if you are using an Instrument track, or “1 - BFD3 - Midi In” if you are using a regular MIDI track.
And for the Input to the track (in either case) I’d recommend your actual external MIDI keyboard, rather than “All MIDI Inputs”. There’s a good reason for this (which might also answer one of your other questions :wink: )… BFD itself is capable of transmitting MIDI (so that you can use it to trigger a different MIDI Drum instrument (e.g. Superior Drummer, or Groove Agent SE). “All MIDI Inputs” merges absolutely all MIDI, so, in the case of BFD, you’d be sending its own MIDI data back to itself!
Let’s see if this makes any progress, even even you aren’t quite “home and dry” yet :wink:.

Hi there!

OK, so I am attaching here a screenshot for you to give you a better idea of what is going on:
Screen Shot 2015-06-08 at 12.06.12 am.jpg
As far as I can see, I have used a MIDI track and not an audio track. And yes, the only problem that I seem to have is not being able to hear BFD playing, though I can see it flying around in the mixer channel.

I did drag and drop the groove into the track… but this is because I don’t own a MIDI keyboard (which I appreciate negates some of your later advice). I’ve not had a problem historically with this method.

So you’re saying that the output field (in the Inspector) should how “1 - BFD3 - Midi In”? Confused as to why it wouldn’t say “1 - BFD3 - Midi out” but perhaps that is a lesson for another day :slight_smile:

On the following screenshot I have shown the alternative channel selection options:
Screen Shot 2015-06-08 at 12.13.57 am.jpg

Either way, I’m not getting a result when I change the ins/outs to the latter options.

O.K. Yes you are using regular MIDI tracks.
Your 1st screen shot shows us which audio inputs are available (e.g. which socket of the Audio6 you plug your guitar into… has nothing whatsoever to do with the BFD, whose audio output goes to the main output of Cubase, which in turn, goes to the stereo output (presumably 1 & 2) of the Audio6 via the USB cable.
Maybe we need to explain, briefly, what MIDI actually is? (in itself, it has nothing to do with audio :wink: )
Can you picture a mechanical player piano (that plays, all by itself, by means of a perforated “piano roll”, where the holes allow the mechanics to open and close)? Well, MIDI is merely the software version of that :wink: (that’s why, when you open Cubase’s MIDI Key Editor window, it even looks like a piano roll :wink: ).
So, the data on a MIDI track does nothing more than tell the receiving instrument which notes to play, and when, and for how long… it has no way of knowing (or even caring :wink: ) which instrument that data is being sent to… if there were such a thing as a MIDI washing machine, it might be programmed to switch to “fast spin” whenever it received a MIDI note of “middle C” :stuck_out_tongue:.

So, the BFD… has a MIDI Input (ready to receive data telling it which notes to play), and a MIDI track has a MIDI output (which sends out that “piano roll” data). (A MIDI track contains no actual audio :wink: )
So, in the Inspector of a MIDI track, there are two fields, one for MIDI in (the incoming signal, which, in your case, could even be left as “not connected”, seeing as how you don’t have an external MIDI keyboard with which to actually play an instrument in realtime).
And the other field is the MIDI Output (i.e. the destination for that piano roll data). So, in this case, it wants to be routed to BFD3- MIDI In (i.e. routed to the input of the BFD3). Using the exaggerated example from above, it could have been routed, instead, to “Washing Machine - MIDI In”! :wink:

Now, as for the audio that the BFD is generating… in your 2nd screenshot, you see a folder track named “VST Instruments”. Click on it, to open it, and inside, you’ll see another folder track (dunno whether it will be open or closed) labelled “BFD3”. This is where the audio from the BFD is actually happening.

As regards the MIDI track, the routing that we see in your 2nd screenshot is almost correct… the Input is wrong (could cause a MIDI feedback loop)… set it to anything other than "All MIDI Inputs or “BFD3 MIDI Out” (in fact, since you don’t have an incoming MIDI keyboard, safest bet would be to set the input to “Not Connected”.
But you say that, even in the 2nd screenshot configuration, you are still not hearing the BFD?
Try a little experiment (if it works, it will sound horrible, but at least we’ll know that there isn’t just silence :wink: )… load another standard Steinberg instrument into the VSTi rack, and change the output from that MIDI track to be now routed to that instrument instead. If all is working correctly, this instrument should now be trying to play the notes from your MIDI drum loop. Do you hear anything or is it still silent?
Open Cubase’s Mixer window. Do you see any activity on the Main Outputs? (there is no reason why you shouldn’t :wink:.
If you are seeing meter activity on the Main Outputs, but not hearing anything, then the problem is with the monitoring.

Please upload another screenshot…
In your 1st screenshot, that window is showing the VST Connections - Inputs. Please show us a screenshot of the other tab, “VST Connections - Outputs”.

You say you can hear your guitar, but I have no way of knowing, at the moment, if you are hearing it through Cubase, or directly from the Direct Outs of the Audio6. So, once again, play your guitar, and see if you see any activity on the Main Outputs of Cubase.
In fact, please also upload a screenshot of your Cubase Mixer window.

Hi there!

So, I changed the MIDI Input to “Not Connected” and it seems to work fine now. ALL GOOD :slight_smile:

Thanks for the assistance and very clear explanations. Much appreciated!

Cool :wink:
Have fun! :slight_smile: