MIDI meters are working, but no output.

Yesterday while in a rehearsal, the project stopped sending. The meters in the Mixer were off. Yet the MIDI meters were working, i.e it received my playing perfectly.

Exiting the project and re-launching it solved it (temporarily - it returned after about 10 minutes).

What could have been the problem?

That sounds like a problem with your soundcard/ASIO driver. What are you using?

Sounds like a Power Saving issue. Something’s being sandmanned.

Try to set all prefs with the word “MIDI” in it to default setting.

I’m not sure what the above suggestion about midi prefs is about?
Midi seems to be working just fine in his setup.

True, Strophoid, but it worked for me, once. And for some others too. Can’t really tell what caused my problem, though. I had working MIDI meters too.
Edit: I did not read the part where the OP wrote that after restarting, the setup worked again, although temporarily. :cry:

Focusrite Scarlett 2i2.

Might be. How do I prevent it?

Turn off power saving for associated objects. :confused:

Probably a powersaving setting for your USB ports then, try disabling that.