MIDI Misalignment in Key Editor........

Evening folks,

I am inputting midi info from an M-Audio Keystation Pro. When I play back the track I have just recorded it is in time and exactly how I played it…HOWEVER…when I open the part in the Key Editor all of the notes are 16th of a beat advanced. If I “select all” and move them back to where I’d expect to see them, they then drag behind the beat. This is really helpful with Quantise as you can imagine!!!

Suggestions Please…Glenn

What is your “reference” you are using to determine if they are lagging when you drag them all back?

If it’s an audio track, it might be resolved w/ one of the usual fixes for MIDI timing errors (google: "MIDI timing errors … Sound on Sound … Timestamp). Otherwise might need more info.

Hiya Alexis,

The reference is using my ear against the click. I have set up a project with a single track for Midi and an audio track for monitoring. I have been through the other posts regarding this matter here and it seems that others have had this problem but no one has posted how the problem was resolved. Thanks for the advice though, I will check it out.

G

http://www.soundonsound.com/sos/dec07/articles/cubasetech_1207.htm

Not sure the system timestamp will help though if it sounds aligned to the click in the project window.

Hi again Alexis,

Many thanks for the link. I have tried just about every combination to no avail. The keyboard was connected via USB, but I disables that and used midi through the card (EMU 1212M) and the result was exactly the same. The bloody sequencer is virtually impossible to use in this condition. It’s great that kind people like you are doing Steinbergs after sales work for them.

There’s a MIDI Timing article at the Knowledge Base that explains how to fix it. No, I won’t link, it’s easy enough to find yourself.

Hi GlennAnnett -

No problem with the (attempt at) assistance here, that is the nature of this community (learn<–>teach where possible, repeat).

If the above wasn’t successful … it might be helpful if you sketch out/describe your connections. Even better if you’re able to post pics of your alignment on the Project Page vs. the Key Editor, and your VST connection page.

Hi MashedMitten,

If you are referring to instance “93” on the Knowledge Base, Yes I had, read, tried, failed, and rated that one already.

Are you sure you understood it? You have to go by the opposite of what they say re: emulated ports and may need to Use Sys Timestamp in conjunction. Sure you don’t have auto Q enabled?

Did you get the Emulated ports to show in Device Setup? Did you select the Emulated port as the specific MIDI input on the track? If it still didn’t work, did you try checking Sys Timestamp in conjunction with the Emulated ports? Still waiting on an answer to the auto Q question.

Hi Mashedmitten,

Thanks for your help, and sorry for the delay. My music machine is disconnected fro the “information super sesspit” and I have just spent a couple of hours in a darkened room thrashing it out with Cubase and the cursed UR28M.
The problem was the settings in the Audio device setup for the UR28. I reconnected the EMU and everything was fine so I knew the problem was with the UR unit. I tried every combination and evebtually nailed it with the syc set to internal, direct monitoring on, and the Sys timestamp checked. (Auto Q was off all of this time…sorry I didn’t manage to answer that!)
I feel that the manual for the UR28 is incredibly badly written and I hope that is not Yamaha’s influence.
Thanks to you and Alexis for doing Steinbergs job for them. It’s got to be easier than this?

G :frowning:

Glad it’s sorted, thanks for posting your results.