MIDI Mixer Channel States Not Persistent When Switching Songs

Originally posted in “Feature Requests” moving here as requested. Issue still present as of version

The MIDI track’s “Grey” fader values do not remain once I switch away from a song but instead revert back to a default value of [-20]. [musicullum] states that it is by design but this is not the case with audio tracks in my testing:


  • I am working with songs using MIDI tracks in this example, so no Layers nor Stacks. These are Instrument tracks in Cubase that get converted to MIDI tracks in VL when importing or simply creating a new MIDI track in VL. Problem happens in both instances, so it’s not a Cubase export/import problem.
  • Each MIDI track in Song 1 is using a separate VSTi (KeysOfThe70’s and HALion Sonic) plus an Audio track. Song 2 is empty. Songs 3 and 4 are purely Audio tracks.
  • MIDI tracks in VL appear to have 2 mixer channels: Orange and Grey. Based on the meter markings on the fader, I’m assuming Orange is for MIDI and Grey is for VSTi Audio.
  • I would like to work with the Grey faders as I have no use for the MIDI channels. This is my workflow in Cubase since that’s where I prepare all of my tracks.
    • The Grey fader always defaults to [-20]. This also occurs if you create a new MIDI track in VL instead of importing one from Cubase.
    • When I adjust the Grey faders, switch to another song and return, the value reverts back to [-20]. Same when I open up the project.
    • Orange fader seems to be the master and Grey is linked it, but I don’t understand how they are supposed to work with each other. Orange fader settings are persistent but are MIDI values rather than dB. Therefore it appears that we cannot achieve more than [-20dB] values.
    • Adjusting the horizontal fader in tracks view moves both faders proportionately.
    • The Orange MIDI channel makes sense if controller external MIDI instruments but is of no use with VSTi’s. Cubase does not render them in that case. Perhaps a new “Instrument” track should be added to VL along with MIDI.
    • This behavior does not occur with Audio tracks.

Simple Project Example - Animated GIF

Did you try ctrl/click on the orange faders?

Yes, grey remains at [-20]. But if I move the orange fader above +5, the grey moves to 0 and appears to be persistent. There’s an asymmetric ratio difference between both of them.

So I guess a workable solution for now is to only use the orange fader to manage the grey one and ignore the orange values.

There is something wrong there and we are on the case.

… we have improved the Volume and Pan controls of the MIDI Track channels. Please try with the next version.