MIDI Nightmare!

Hi all,
Really hoping you might be able to help. So I recently added a Roland JU-06A to my outboard arsenal. As I’m using El Capitan, I’m not able to connect this via USB (minimum sys requirements is Mac OS X 10.12). However, I dodn’t see this as too much of an issue as I thought I could just connet via the midi ports via my midi interface. However, it seems that this creates a crazy midi feedback loop because as soon as you try and record any CC data from the JU-06A, things go mental and an unstoppable stream of midi data starts being sent out, even if you’re not touching any parameters.

So I figured I’d deactivate the MIDI Thru option in Cubase Preferences, but that seems to stop any midi data being sent back out of my midi interface to any of the connected synths etc. All of my outboard MIDI gear is connected to its own input and output on an Emagic AMT8 and MT4. I’m using Cubase Pro 10 on a Mac Pro 3.1. Is there any way to disable MIDI THRU, but still send MIDI out of the correct ports on my interface? The JU-06A does not have a local control so I can’t turn local off at that end to get round the issue.

Any help anyone is able to offer would be hugely appreciated!

Many thanks


Just to add, Roland have got back to me and said that I need to switch off the “software thru” also known as a “Soft Thru”. Does anyone have any idea whether this differs from the Midi Thru option in the preferences within Cubase?