MIDI Noob needs help cubase 5 essential

OK, I’m totally new to midi. I have a Casio ctk-5000 and an Alesis Q25. Both use usb midi. I can not figure out how to get them to work with cubase. I’m running XP 32 bit and have a Line 6 UX1 for sound. Any help or tutorial would be greatly appreciated. I’m beyond frusted.

Did you turn them on before opening Cubase? Are they listed in Device Setup MIDI Port Config.? You do know if you want the sounds from them you need audio cables in addition to the MIDI and an Audio track in Cubase set up to monitor the audio, right? A better explanation of exactly what you’re trying to do and where it goes pear-shaped would help.

Yes, I did turn them on before opening cubase. I would like to use them as controllers, but when I open the midi device manager neither are listed. In my windows device manager I see they install as a usb audio device, but I do not see them any where in Cubase. I tried selecting GM device and midi device manager and that didn’t work. I can get sound with Halion using the virtual keyboard, but not with either of the keyboards. Is there any guide that breaks this down “barney” style for the midi challenged like me?

You don’t want the Device Manager, you want to see if they’re listed in the location I mentioned. If so, you select one as the input of a MIDI track and a VSTi you’ve loaded in the Rack as the output and monitor enable the track. Playing should produce sound.

Make sure the track is set to No Map, also.

I don’t see them in the device setup either. Should unistall the general midi from the Midi device manager?

Device Mgr shouldn’t matter as long as No Map is selected on the track. Are the devices using generic Windows drivers or did they come with their own? Have you tried re-starting the entire system? Screenshot of the Device Setup window?

Using generic windows drivers. Just for grins I plugged the q25 into my laptop and it did come up in cubase. No sound but I saw the input levels moving. I’ll try to get a screen shot on my desk top. Not too sure how to do that.

Hit Print Screen, open Paint, paste there then save as JPG and attach it to a post.

Not sure if this will work or not.

Where do I check to ensure the No Map is not active?

You need to attach the file via the section below the post window. The No Map is on the MIDI track.

Ok, here it is.
sreen shot.JPG

I do not have Map selected either.

Close Cubase and trash Prefs then re-start Cubase. You’ll have to select the correct ASIO driver etc. after. My sig has a link as to how.

Thanks! seems to be working now. Shows up in device set up and controls halion fine. Appreciate it.