Midi not being received by Vsti or external modues

Hi. Seemingly got a major problem with Cubase 8.05. Yesterday everything was working fine. Today I am unable to trigger ANY Vsti’s in Cubase using my keyboard controller, guitar controller or my Launchpad.

This happens everytime I use Cubase 8 irrespective of whether I use Steinberg Vsti’s of 3rd party Vsti’s

I am using Windows 7 (x64) with a dual xeon processor - 128gig ram

Midi is being recieved by Cubase as I can see it in the transport bar. I can see it responding to note on / off_pitch bend_modulation etc. I have checked the output from my keyboard controller using MidiOX and it is transmitting fine.
My midi controller is a Nektar P6 and is showing as active in the devices setup.
I can hear the Vsti by using the mouse to play the virtual keyboard in the Vsti(if there is a keyboard in the GUI) but when I play the keyboard controller the midi indicator on the Vsti is not lighting up and there is no sound.
If I input midi data onto a VSTi track with mouse (as I cannot input data using the keyboard) it will play back fine.

I also have Reason and Ableton. My keyboard controller works fine in these programs.

I also have Cubase 7.5 and it works fine with this. I updated to 8.05 last week and it has worked fine up to today.
I have just completed a windows update tonight and that has had no effect.

Any thoughts or help would be welcome. I absolutely love Cubase and have been using since it was on the Atari so I am pretty desperate to get it up and running again.
Thanks Jon

Just a quick addition / update to this issue I have. I can record with my keyboard controller into Cubase. However, no midi is transmitted to the VSTI during record. Sound and midi activity only appears on playback.

Hi JonnoRAS, did you ever get this sorted - I’ve just started to develop these problems in the past 3 weeks- I’m on 8.5.3 and is the exact same as you described.

winnie67