MIDI not lining up - SOLVED

Thought I’d post this in case anyone else can’t find the solution. I’ve been hunting for a solution to an apparent MIDI timing problem where I would record something with MIDI and it would not line up on my bar lines no matter what I did.

After several searches and experiments I found the solution. In “Track Controls” (right click in the Track area) I had to add the “ASIO Latency” button to make it visible. When activated my problem disappeared. Then in Preferences > Record > MIDI I checked “ASIO Latency Compensation Active by Default”, exited my template and reopened it. All MIDI tracks had an ASIO Latency button and all were activated and my “sync” problems have disappeared. It is not necessary to have the ASIO Latency button present on the tracks so I hid it again in “Track Controls”. This has been bugging me for almost 6 months. Posted FYI.

1 Like