Midi note data is doubling

Guys I just noticed that in Cubase 12 Pro I was getting some weird flanging/chorusing with my new Spitfire string library. I contacted Spitfire and for four days we tried to figure out what was going on. We never did figure it out and wasn’t able to recreate the issue however I just noticed that nearly every track with midi data using a Spitfire plugin VST instrument each midi event is doubled. Meaning that each even has another event exactly the same in pitch, velocity and duration directly under it. So if I move the midi event I can see this second “twin” even under it. Any clue what might be causing this?

I check other midi tracks like my piano track and bass track that is using external midi modules…no such thing is happening.
Any thoughts?


Attach the screenshot of the Studio > Studio Setup > MIDI Port Setup, please.

Hi Martin.
Ok thanks. Here it is:


I was thinking the MIDI In Ports are going to be doubled by multiple driver types. But this is not the case.

Could you try to Disable Preferences, please?

Martin I’m not sure what you mean by Disabling Preferences.
Can you explain that a bit more please?

He is referrign to Safe Mode Dialog

Thanks Steve.
Ok I just disabled it.
What’s the thoughts behind this possibly stopping the note doubling on some VST tracks?

Preferences that are somehow corrupted, that’s all. Have you tested yet? All good?

No it’s still happening.
I disable the preferences but after I did that I didn’t see my project in the hub anymore.
I think I may have did this incorrectly. So I disable prefreences in the safe mode dialog but then what…find my project manually using the file picker and navigate the the location of the project and see if that helps?
I think what I may have done is disable it but then when I didn’t see the project in the hub under Recent I had a minor panic attach and don’t think it took.

I’ll test further but it only seem to happen on VST instrument tracks not midi that is going out to outboard gear.

To be clear…when I go into the midi editor of the track and use my mouse cursor without any of the tools and drag up or down one of the midi events…there’s another even of the same duration, pitch and velocity directly under it. Am I correct to think this is a second note/event…or could Cubase be “copying” it with some special feature that I may not know about?


Did you record the MIDI data other way to the Instrument tracks comparison to the MIDI Tracks?

1 Like
  1. Have you used “all midi in” to record tracks?
    If so, what happens if you just select a master keyboard to the input?

  2. What happens if you record MIDI notes from the virtual keyboard?

1 Like

Have two boards. Only the piano is done with one specific keyboard on port 1 channel 1. Everything else is played with a second board on port 2 channel 1. So strange

I disabled the “all midi in” and have the track that I’m recording on set to port 2 channel 1 as that’s the board I typically use to play everything put piano.
I’m looking for the virtual keyboard to test it but all I’m find in the manual is the computer virtual keyboard not the piano keyboard.


1 Like

Hmm that’s not what I expected. I thought there was a larger more graphical piano keyboard.
I’ve saw a much larger more more detail graphical piano virtual keyboard in some videos about Cubase. Hmm Maybe it was a separate application?

Probably a plug-in. A lot of virtual instruments display a keyboard in their window. Comes in all shapes and sizes.

1 Like

Ahh. Ok thanks man. After poking around in the Cubase manual and finding nothing like what I remember seeing I was thinking the same.
Thank you

Ok on the "on Screen"keyboard doesn’t generate midi to the plugin at all. No midi activity. And the midi keyboard within the Spitfire plugin also doesn’t generate midi data on the recording track.

For the on-screen keyboard to work I believe the track’s MIDI input has to be set to “all MIDI inputs”.

Plugins do not output MIDI by clicking on their visual keyboard, you can’t record MIDI like this.

Have you tried tweaking the MIDI Thru setting in Preferences ? Double notes can be related to this, but generally this is more of an issue with hardware instruments.

Can also come from your keyboard’s own settings.


Louis your a freakin genius. Of course. As soon as you mentioned “can also come from your keyboard’s own settings” I thought to my self “AHHHH LOCAL is enabled!” yup
Thanks man. You rock
Thanks guys for all of your efforts and input. I truly appreciate all of you.

1 Like