MIDI note input is off with MIDI keyboard


It seems that my MIDI input is not lining up with my MIDI keyboard. For instance, I have a VDL low tom from 'Rack Combo A" programmed for MIDI note 60 with the note C4 in a percussion map, but it is sounding on E4 on my MIDI keyboard. Any help is appreciated, thanks.

Check Preferences under Note Input to use Percussion map.


1 Like

Thanks for the help. I changed that, but it’s still off. I attached a screen shot of what I see. I am using an 88 key MIDI keyboard, I am not sure if that has anything to do with the settings?

I’m not entirely sure what you mean by this, @mameza7. It sounds like what you’re saying is that you have specified that you want a particular sound in the VDL drum map to be played when you play C4 on your keyboard, but that’s not the way it works: either you can use the pitch in the VDL patch itself (i.e. as shown in the VDL documentation) by choosing Use percussion map in Preferences, or you can play the note corresponding with the staff position, assuming that the five-line staff uses either a treble G or bass F clef. What you can’t do is change the pitch in the percussion map and then expect Dorico to produce that sound when you play the key: Dorico cannot change the way the sounds are organised in VDL’s Kontakt patches.

1 Like

Thanks for the help. Yes, to be specific, I am following the Tapspace article here: Virtual Drumline Tip: Integrating VDL with Dorico Notation Software - Tapspace News

Foe example, with the VDL documentation that’s on the article, it has “low tom” from the VDL Rack Combo A as MIDI note 60, note name C3 (in the article it’s programmed as C4 because it said it’s the same thing, just using different definitions). When I play that on my midi keyboard, it doesn’t sound, but it looks like when I play E4, the note sounds.

Now, when I close the file and reopen (I made sure the MIDI keyboard is on before I start Dorico), when I play my MIDI keyboard, it looks like it is sounding everything correctly from Rack Combo A as it should be, in terms of the correct MIDI notes and note names, but then when I try to write the notes in “write” mode, that all goes away, and it looks like every MIDI note is moved up a third. For instance, that low tom that should be MIDI note C4 is now E4.

Also, the only instrument that is sounding when I play it back is the snare drum. I’ve attached some screen shots in the file, hopefully that helps.

In your antepenultimate screenshot it appears that you’ve reverted your input preference to “Use staff position”. It should still be on “Use percussion map”.


What happens if in the middle screen of your grouping here you selected Use Percussion map in both instances where it is an option instead of using staff input at the top?

1 Like

Thank you for the help! When I changed the “input onto kit or grid” from “use staff position” to “use percussion map,” it now works and this problem is solved!

Thank you for the help! This worked and now this problem is solved!