Midi note lenght in pianorol can not be shortened

Create a midi track
Create a part and doubleclick to open pianorol
Draw some notes with quantise on 16th
Change quantize to 32th
Crtl A to select all notes
Grab any of the notes at the end
Moving the mouse to the left while holding the left mouse button no longer shortens the length of the note to the new quantize value, please note you can still make them larger.
Can anyone confirm please?

EDIT: not a bug, seems my project file (created in 7.5) is screwed.
New empty project file works fine aaarggghhh…

Is the “quantize length” setting in the 7.5 project still set to 16th?

That could be very well be the case, though lengthening them 1/8th locks them at 1/8th, it seems it’s able to make them larger but not smaller with the mouse clamp
Function > fixed length in the context menu does work though.
I’ll see what happens when I move all content to a new empty V9 project file.