Midi note overlapping midi event

Hi,

I´m trying to figure out if it´s possible, like in Logic, to make Cubase play a note that´s overlapping the actual midi event?

I have attached a picture so you can see what I mean. In the picture Cubase doesn´t want to play the note. But in logic this is possible, which to me is extremely important to my workflow.

Look at the “Logic example” picture. That´s how I wish it worked in Cubase. So much easier to handle everything, even if the notes starts just a bit before the midi part (which they almost always do for me).



Cubase midi.jpg

I usually just enlarge the event by dragging the edge or when adding the midi note that is outside the event I get a warning that I am placing the midi note outside the event. Then I just choose the option for Cubase to enlarge the event. Notes on overlapping events will play.

Regards :sunglasses:

That would be awesome…

-> also at the end parts :wink:

Mm… That´s the way we are all forced to work (if I´m not hopefully wrong). I have added pictures (in my first post) of how it works in logic, that´s the way I wish it would work like in Cubase 8. I´m always recording live with my piano, and most samples in my libraries needs to be triggered before the first bar. If you look at the “Logic example” picture, most (if not all) midi notes in each midi event starts before the actual midi event (like in the “Logic midi” picture), and is played anyway in Logic. That´s why this is extremely important to me. I find it very messy having to enlarge each midi part so Cubase doesn´t mute the notes that is starting before the event.

If this is not possible, then this is a feature request!!!

In your example there (just for info), how did those notes end up outside the Part in the first place?

Because I´m playing everything in live, just like I explained in my last post:

" I´m always recording live with my piano, and most samples in my libraries needs to be triggered before the first bar."

If they are not starting before the bar, they will start sounding too late. Using a legato patch with a slow sample start is one example.

That doesn’t answer my question :wink:
Depending upon the setting in Preferences>Record>MIDI, the MIDI Part will begin either where you start recording, or start at the bar-start prior to recording. So, how did you get to record live, but have the MIDI Part start later?

Aha. I´m draging the midi part to line up with the bar after I record =)

And then irritatingly enough, Cubase mutes the notes that´s outside of the event.

(Ah, that explains that :wink: ).
Yes, that is a function unique to Logic. In Cubase, the workflow would have to be different… don’t drag the MIDI Part start, but when you want to move/copy the Part, set Snap to Grid Relative.

Good follow up questions and answers. I assumed the OP was adding midi notes. Cool :wink:

Regards :sunglasses:

I don´t see why this could not just be added in Cubase. Simply don´t make Cubase mute notes that are outside a midi part, just add that in the preferences…

But only those notes that are (partially) “in” the event obviously… Not that some note plays 33 bars later and you dont know where it came from…

Yes exactly. In logic I think there is some limit of maybe a quarter note. So if I drag it to much outside, it will ask me to enlarge the part. It´s perfect. The option should be in Cubase, maybe also with the option to choose how many ticks outside the midi events will be possible without the note to mute.

Here is a picture to clarify what I´m after. Just like cubase plays notes that´s overlapping at the end of a midi event, I want it to also play the notes that are overlapping at the beginning of a midi event.
Cubase midi overlap.jpg

I definitely see what you are requesting and I don’t disagree with it but what am I not understanding here… :question:

I always record my midi live and I never have this problem for the notes that I recorded live. I only get this issue when I add notes in the midi key editor. But it’s really no issue for me because I just click on the “Enlarge Part” option when it pops up. Easy.

My workflow is… “Record Enable” the midi track (though 90% of this time I record on a instrument track). Then press the “Record” button and start playing something to a click. So I don’t have any notes that fall outside the midi part until I later do some editing to add some.

Regards :sunglasses:

for me: i record midi… sometimes the notes are not on the grid-
then i want to loop a part for further editing, adding new stuff, whatever…
in this loop, the first and last notes do not play fully, so the loop sounds weird…

  • this could be from a midi recording of sometimes a few and sometimes hundreds of bars long… out of these many bars, i want to loop a small part and edit it… but the loop sounds weird because notes get cut off…

just to explain one scenario :wink:

Yes we all have different workflows. And that´s my point here. Cubase doesn´t let us have it. My workflow is: hit play button without a click, play something in, if I´m happy with it, hit shift + *. And then fix the grid so it lines up with the part. Then I want to keep my overlapping first note/notes, but I don´t want overlapping midi events. Just like in the picture I´ve attached. Almost all the midi events in the picture have overlapping first notes. But the events them selves are not overlapping. Works perfectly for me. And I wish it was possible to have it like this in Cubase too. If you want. Add the option in the preferences so you can have a choice.

I see your point, im struggling with this too.
wish steinberg improve human playing feel “mistakes” in account and includ them into logical midi events// just like in Logic example

Well, I’ve read this several times and it seems to me you could achieve what you want in one of 2 ways:

  1. Start your recording event at measure 3, that way if you record a note before it,say, 2.3 the pre-note will be recorded.
  2. It sounds like you may have clock issues perhaps caused by your plugin meaning there is a slight delay between hitting a note and the event recording. This can be compensated using the ‘Constrain’ button