Midi Notes early (or audio is played early)

Yikes!This is worrying.I will check mine and post back.

Same VERY ANNOYING problem here for audio only (for some reason the MIDI issue has gone).

Running 8.0.10, Windows 7 64 Ultimate and RME Fireface, 256 buffer, ASIO Guard set on HIGH.

Worst thing about this is when I manually move an audio clip to the right position it stays “in advance” when I duplicate the same clip again, this is even more f*cked up knowing that I snap/trimmed the beginning/end where they should be.


I had the same problem with midi notes being played too early. Could not fix the issue no matter what. So I made some custom metronome samples with a slight delay to them. Fixed my early note problem lol :sunglasses:

1 Like

The number of ticks the midi is early is tempo dependent, so this negates the possibility of a workaround of using a logical editor to move notes to their proper position. Moving by milliseconds can get closer, but, again, tempo changes make this method an inaccurate one.

I’m taking Steinberg’s silence on this matter as a sign that they might be looking into it and are probably concerned. I can’t imagine they would simply ignore something as important as midi timing.

To see if you have this problem, do the following-

  1. Add a midi track and record two quarter notes. Quantize both notes so they are exactly on the beats.

  2. Set the output of this midi track to an IAC driver bus. (on Mac)

  3. Create a second midi track and set the input to the same IAC driver bus and the output to anything else.

  4. Record the output of the first track into the second.

Result= The midi notes recorded into the second track are earlier than the first track. (If you begin the recording directly on the bar containing the notes, the first note will be correctly placed and the second will be early)

As I said before, the amount of displacement is both tempo and buffer size dependent- making a workaround difficult at best. Cubase 8 is so good otherwise that I hate to experience this issue. I had been noticing subtle timing issues and decided to investigate and it seems I’m not the only one with this problem. I remember in a much earlier version of Cubase on Windows a fix having something to do with ignoring a port filter, or something like that. If anyone has a solution for Mac, please let us know. In the meantime, I guess it’s back to DP8. I’ll miss Expression Maps, VCAs, the Control Room, and so many other things, but I’ll be back when this is remedied.

8.0.20 still has the problem. Oh well, I got excited for a moment.

Steinberg is silent about it because no one posted this in Issue Reports yet…

My bad. I thought someone had reported the issue.

Will anybody who has done the tests, and even a YouTube video, report this?

I´m no expert on this stuff, but is this related to the problem?

I remember that problem many years ago when I was using Windows. I’m on Mac now and I don’t know if it’s related or not.

I’ve just reported it.

Did you include reproduction steps and a summary of our collected information in the thread? If not, then I’ll do an additional report of my own.

I had a similar problem a while back. Was solved by doing a midi port reset, might not be the same problem that you’re having but it’s worth a try.

Here’s the the thread: Recording MIDI = everything is in advance - Cubase - Steinberg Forums

I followed the advice that worked for that person, but it doesn’t change anything.

Can this offset be adjust manually? In FL Studio it’s done by setting setting “Offset” slider to -100%.

Yes, I did, but feel free to add to it.

Ah, then it will probably be accepted, so if needed I can just post there when it’s up.

Thanks, will try. Do you have System Timestamp for Windows MIDI Inputs on or off?

Unfortunately, this did not work for me either. :cry:

I have them on.

Did your topic get (dis)approved?