Midi notes latches the "wrong" way in the key editor

Cubase 11 pro on Catalina here.
The issue is fairly simple but I cannot find the setting to change it.

When I’m in the key editor and the BACK of my midi note sticks out a bit over the grid,
I want it to end ON the grid and so I turn on snap → grab the midi note and drag its back part left.
Instead of latching on to the grid on its left, the note goes all the way to the right.
it seems as if the note wants to stretch over a BAR.

The issue does NOT occur when snap is off, but I need it to have the accuracy of snap obviously.

Thanks to all those who help.

Most likely this is caused by the Length Quantize setting in relation to the Snap Type & Quantize Preset settings.

Yup! that did it!
Thanks a lot Raino!!!