Midi Notes Loss when playing more than 3 Midi channels


First, here are the repro steps :
0. Make sure you are outputting to an audio interface and let’s say 3 midi compatible instruments.

  1. Open New Project.
  2. Create 3 new MIDI tracks.
  3. Assign 3 MIDI tracks to different channels.
  4. In every MIDI tracks, change the delay to compensate the latency (or MIDI Thru latency if there’s more than 2 devices plugged in). (Try -25ms, -50ms, -75ms)
  5. Make a basic MIDI sequence. (like C1 every 1/4th note).
  6. Play sequence and observe MIDI Interface/Instrument.

Repro is around 75% of the time.

Result : Some notes will be not playing sporadically at higher delay compensation.
(Current) Setup : Mac OSX 10.11, CPU i5 6600K, GPU GTX980ti, MOTU 828MK3, Cubase 8.5.20 64bit

Workaround :

  • Use lower MIDI latency compensation
  • Probably gonna use a MIDI splitter at that point to make sure I’m sending everything on the same latency.

Notes :
Alright that’s a long story : I’m getting this issue since Cubase 6.5 where working with higher delay compensation will just start skipping the notes altogether. At first I though it was my configuration where I’m daisy-chaining 3 synthesizers in a row followed by splitting the signal to two others.
I made a couple of verifications at the time to make sure if it’s not a faulty MIDI cable or the MIDI thru of one of my synth acting up (shouldn’t be the case usually). Turns out it’s actually Cubase that is skipping some notes as per the GUI (Notes ON/OFF signal not activating upon the notes once in a while).
What I did so far :

  • Cleared my preferences entirely.
  • Upgraded computer (was on Macbook Pro 2010 when I first encountered that)
  • Upgraded OS (10.6.4 to 10.9 to now 10.11.5)
  • Checked other DAWs and tools that I’m using (not losing one single note in the others)
  • Upgraded from Cubase 6.5 to Cubase 8.5.
  • Switched Audio Interface to another one (Focusrite Saffire LE + UR22) just in case it’s miscommunication between the software and the interface.

It doesn’t need to be 3 midi tracks at the same time. As long as you have something above -50ms, it will start doing this.

I contacted the Support previously with a video of the UI not playing a 4 1/4th note sequence. Unfortunately, I’m in Canada therefore I ended up with Yamaha whose answer was “we don’t know. Try upgrading your Cubase version” which results in today where I’m encountering the same issue for 3 years in a row.
Is there a possible hot fix or patch that can be done to resolve problems at higher MIDI latency compensation at this point? I don’t understand that I’m not getting this issue in other DAWs and that it’s only specific to Cubase at this point.