Midi Notes Not Playing

Hi All, I’m a new Cubase user and it’s been tough getting started.

I’m recording midi tracks from my keyboard (Modx) into Cubase and the problem I’m having is that some notes are not playing even though I’m pressing the keys. Usually it’s when I’m playing large chords or holding down the sustain pedal. When I’m not recording I don’t have this problem at all, the keyboard performs normally. Let me know if there’s a reason for this. Thanks

No reason for this to occur. So, few things to look at, at first :

  • Even if not heard, are the missing notes recorded (do they appear in the key or list editor) ? Which are the notes missing (range, channels) ?
  • Are you recording on true MIDI tracks or instrument ones ? If the latter, which VSTi is/are involved ?
  • Are you sure that the Preferences > MIDI > MIDI thru Active option is ticked ?
  • Maybe it’s worth to also check again that there isn’t any MIDI filtering (MIDI channels) occuring in the Preferences > MIDI > MIDI Filter page, or any Input Transformer module loaded.


What do you mean by this, please?

I think this sounds like the polyphony of the VST instrument has maxed out.

1 Like

I am recording on true midi files, the sounds are transmitting from a performance in my modx. I don’t know if all the missing notes are recorded I am not that advanced yet. However, even if they are it’s very hard to record with random notes cutting out.

I’m sorry, where is the midi preferences menu in Cubase? Could it be something to do with the midi syncronization settings?

Not sure that I got what you are doing. Do you mean that you are playing over already defined ‘MIDI loops’ ? On your screenshot, I see MIDI tracks but no association with them. So, i still think it would help us to have answers from my previous post, as it’s difficult to see what’s going on without these informations.

Beside this, forget everything related to the project synchronization seetings, unless you are using an external MIDI sequencer. Again, you can check what has been actually recorded with the Key Editor or the Edit In-Place command.

As a side note, the MIDI preferences in Cubase are located in the Edit > Preferences > MIDI panel.

what I had is a single midi track looping in Cubase, a short drum loop from my keyboards arpeggiator that I was recording to. All of the other tracks I’m recording are not on loop.

Cubase has some sort of issue with only being able to transfer a limited amount of midi data back to my keyboard when I’m recording. In my modx settings I had local control turned off, so that I would only hear the midi notes in my headphones after they were sent to Cubase and then sent back to play through my keyboard sounds.

Now that I have turned local control back on I can hear all the notes again coming my keyboard. It works, but let me know if there’s a better solution like a Cubase setting.

A tutorial I watched about recording Modx in Cubase had said to turn Local control off on my keyboard, because it could create a note doubling effect with the sounds coming from both the keyboard and Cubase. Since I turned local control back on so far this hasn’t happened.

Local Control: On/Off - this means that on your ModX the keyboard triggers sounds of the ModX and sends MIDI data (Local On) or that it only sends MIDI data (Local Off). In the latter case the keyboard sends midi to Cubase, Cubase then sends it as per your settings, e.g. back to the ModX where then the sound gets created.
With Local Control On you could therefore indeed get a double sound (directly and additionally through MIDI).

Is there a way to have local control on and not get double sound? (So I would only hear the track I’m recording through Local Sound and not Cubase? When I went fully through Cubase notes were cutting out as previously mentioned so double sound is still better then that lol.


You would hear what is the hardware playing, but you would not monitor it thru Cubase.

You can disable MIDI Thru in Cubase Preferences.

1 Like

Wow that fixed the problem. Thanks! I checked the settings and midi thru wasn’t active. How that box isn’t checked by default beats me. Now midi thru is active I’ve turned off local control on my keyboard it works perfectly.

This setting isn’t even mentioned in most online tutorial videos about setting up midi in Cubase but it’s pretty damn important lol. Thanks again.