MIDI notes outside of the part boudaries?


I have a long part with long chords. When I make smaller the right end of the MIDI part, the notes inside will still sound after the part is ended.

How to disable this features so as to mute the notes when it reaches the end of the part?


Hi Baci,

I’m afraid, there is no this kind of Preferences. You have to cut the note(s) manually as far as I know.

Then this is pretty strange.

Why do I get sound from a section of a MIDI part that is not available on the Project window? I would not call it a feature then… sounds more than a bug, I think this is not the expected behaviour. If a part is not there, notes inside should be cut as well.

Try this…
instead of dragging the end boundary, to make the part smaller, Split it at the desired point, making sure you have enabled the following option in Preferences…

Preferences>Editing>MIDI>“Split MIDI Events”

This will indeed “chop off” the trailing notes (placing the remainder of those notes into the new Part after the Split), then all you have to do is delete the Part that was created after the split.

For info, the reason that notes continue after a Part boundary, is because what Cubase actually “records” isn’t two separate events (a note-on, followed by a note-off), but just a “note-on”, together with its length. This is to ensure that, if you do cut and then mute/delete a Part while a note is still playing, it won’t lose its eventual note-off (and then hang on forever! :wink: )

Great, will try, thanks for the explanation!

An old thread but I want to add my thoughts on this.

As vic_france mentions, splitting parts is a way to work around this behavior. Unfortunately though, this reduces the usefulness of working with “shared copies” of midi parts.
Let’s say I have a part that repeats identically 8 times. Normally I would just make 8 shared copies so that I can keep editing the part. But what if I want every other shared copy of this part to be shortened by a forth? I can just drag the end of the parts that i want to shorten, unless the parts have long chords like OP which then will not work and thus I have to convert these parts to real copies.

No one probably cares about this but still, it would be nice if there was a tick box in options that makes all midi part end send not off messages for notes that are shortened.