Midi Notes Recording EARLY???

I’ve been having this problem for about a year, ever since I went from Cubase SX 3 to Cubase 5 (fresh install of EVERYTHING)

When I record midi notes, they come in EARLY…about 1/32 note. I’ve tried EVERYTHING.

Here’s a list of what DOESN’T work…


  1. System Time Stamp. No combination of this works.

  2. Constrain Delay Compensation. Had it working once, but preferences were mysteriously erased…hasn’t been working since.

  3. Midi Port Filter Ignore. Removing that file and doing any combination of active midi ports and system time stamp doesn’t work.

    Right now, my system consists of Cubase 5.5.2, on an i5, 8GB Ram, 2TB total HD, with a Presonus Firestudio box. Midi is connected via external USB midi controller, and USB from Roland Fantom, and standard midi cables from the Korg Triton.

    This exact same setup worked flawlessly in SX 3. After the jump to Cubase 5 (again, completely rebuilt system), I’m experiencing this issue.

Took off work and called in to Steinberg support twice (i’m EST), and they basically told me they had no clue what was going on.

It’s frustrating enough to make me sell this version of Cubase, and switch to Pro Tools, or something OTHER than Cubase.

Oh…and I searched the new forum, and didn’t find anything, so this is why I posted.

Any Clues??

Thanx in advance!

Cubase Early MIDI issues

I’m taking a shot in the dark, but I suspect that the USB is your problem. I had a Tascam USB interface with SX3 and then Cubase 4 and had the same frustrating problem – early MIDI notes. I switched to a EMU 1616m interface which uses standard MIDI cables (and communicates to the computer on the PCI bus) and didn’t have any problems.

So for a long time now I’ve believed there’s a fundamental problem using USB to record MIDI – on SOME SYSTEMS. In fact, there was a post some years back in the old Forum that Steinberg had discovered this problem but no fix was ever announced – never heard a thing about it again.

If your ext controller has regular MIDI capability, try it along with your Triton and see if it helps. You didn’t mention how you’re getting MIDI from the Triton into the computer.

That was a great way of being a smart ass. I’m gonna have to use that!

But if you can find a solution for me in those results, that doesn’t point to the above solutions I’ve outlined that don’t work, I’ll paypal you $50 right now.

Same thing happens from all the sets of keys…standard midi and USB. :frowning:

Get MIDI-OX and do some loop back timings without Cubase and see what you timings are just through the USB device.

EDIT: sorry for being a smart ass… it’s one of my many failings. lmgt4u is the best site on the intertubes.

Forgot one thing, if the notes are consistently early, you can adjust the timing of the MIDI track.

Adjust the timings how?

And the midi timing issue happens through any interface…USB or standard midi.

There is a parameter on the MIDI track itself. Sorry, I’m not at my DAW until much later tonight. I can’t remember the name of the option. It’s like MIDI offset or something like that.

And the midi timing issue happens through any interface…USB or standard midi.

I’m not sure what you mean by “standard” midi here. USB is a standard MIDI implementation.

Here’s a simple test inside of Cubase. Make a MIDI event and add 16th notes to it for a measure. So, 16 beats. Send that to MIDI out … and record that on a seperate MIDI track.

Now zoom in and see what your offset is. You should be able to set the track to compensate for that drift.

I’m gonna explore that…but setting that parameter for 40 some midi tracks per project is gonna get REALLY annoying. :frowning:

I hate work arounds…I just want work RIGHTS.

I’ll let u know the results.

Make sure you don’t have auto quantize enabled. When you tried System Timestamp, did you restart Cubase for it to take effect before trying it? You mention the port filter. Did you select the Emulated inputs for your device after enabling emnlated?

LOL, MIDI workarounds are works right. Compared to what you used to have to do to get outboard gear to behave, this is nothing. Buffer size optimizing, sending drums early, strings late ON PURPOSE etc… etc… just to keep from stopping/choking all together.

You know we used to walk to school up hill … BOTH WAYS!

Did all that except for redrafting cubase. I’ll try that.

I’m comparing it to the cracked version of SX 3.

I went legit, and ive been regretting it every step of the way. The only great upgrade I’ve gotten is Vari-Audio.

I am NOT trying to be a smartass here, but there IS one way to avoid early MIDI notes: don’t use MIDI. Hook up your cables and play your keyboard parts in thru the audio au naturel. Sure, you won’t be able to fiddle with fine tuning your notes, etc., but your performance will be more natural, without the inevitable MIDI latency problem. You might have to do numerous takes to get it right, but so what? This isn’t tape, it’s all digital – you can record as many takes as you need without incurring signal loss, etc.


Use your Triton’s sequencer (linked to your DAW) to input your MIDI performance. Then, either record the audio, or record the MIDI into Cubase FROM your Triton (most workstations do this). I’d be interested to hear if the MIDI is off using this method.

Adjusting the MIDI position is NOT the answer I’m afraid – very imprecise.

In any case, you have my sympathies. As I reported above, I’ve had my own early MIDI problems. It sucks. And what really bites is, the older versions of Cubase worked perfectly in this regard.

I had early midi problems on my last PC. After I upgraded the drivers for my motherboard, the problems went away. So the timing issues could be OS/driver related.


The reason I suggested doing testing with MIDI-OX is that it allows you to figure out where the problem is. You can use the MIDI Monitor in Cubase as well, but it will just show that your MIDI is early. You already know that. There are sooooo many things that can cause that problem that it is really hard to do more than just give a list of things to try. Then the person trying “Thinks” they have tried, but don’t really do it right ( I include myself in doing this). MIDI timing is a difficult thing to get ironed out once it shows up.

I tried that on my last system. Didn’t work. Now I’m having the same issue on my new system.

Same problem, 2 systems. The only thing that even remotely similar between the 2 Rigs is the use of a Presonus audio interface, and Cubase 5.

I have this problem sinse i started using Cubase, in 1997.
Many different PC configurations since then, but always same problem.

Today i was doing some tests and i found that the “early” time is equal to the “Output Latency”. In my case: 23ms.

So, i can have midi sounding in time if i put 23ms in the “track delay” field… for each track!! But the problem still there, when i open pianoroll. Sometimes it’s suficient to set the quantizations wrong.

So, searched entire cubase but din’t find anything to solve this.

Already tried system time stamp, and many other things, in many ways. I thing i get used to this, after all this time.

To be honest, i’m probably about to give up on Cubase, sell this version (which I’ve only had for a year), and go with something like Studio One, or maybe even make the Pro Tools jump.

It’s just said, cuz I was a happy SX3 user until last year, when I made the jump to 5 and since then, I’ve barely been able to work, because of all the issues.

And the fact that this is gonna be the 3rd major releases (4, 5 and now 6) in about 4 years time doesn’t look very good either. Seems like they KNOW they have serious issues with the Cubase line.

I guess that’s what I get for buying the actual licensed version and trying to be legit.

Guess no good deed goes unpunished.

Sorry Steinberg. You lost a customer.