MIDI Notes won't turn of randomly

Hello,

first of all, I spent a lot of time googeling this problem and reading all existing topics about it and trying out all suggestions, but nothing worked.

When I try to record my keyboard via MIDI I always get hanging MIDI-Notes randomly, When I play legato it seems to happen more often than when I play staccato. I use a very simple USB to MIDI Adapter on a Windows 8.1 Computer.

Here’s what i tried out:

I tried all different USB Ports of my computer
I used MIDI-OX to log the input signals - everything seems okay, all note-off signals are sent correctly
I tried to fiddle around with the buffer size of my audio driver
I deactivated Aftertouch
I tried out several, not to say all MIDI-Filters
I tried to use just the single MIDI-Input instead of “All MIDI-Inputs”
I tried to record the MIDI Data in another program (Magix Music Maker 2013) which worked just fine.

Because of the last point, i came to the conclusion that it has to be a problem with Cubase rather than a hardware problem.

Can anybody help me?

Hi and welcome,

Read this thread, please.

Hello,

thanks for you reply. i read the aritcle but did not really get the point.
What did he mean with “Can you observe the same, when you record the data, and play it back from the project?”

Nevertheless, i did some further research on my problem. I used MIDI OX to monitor the input data and there seems to be something strange. When playng two notes and releasing them in opposite order, he swaps the channels, on which he sends the note off singals (See screenshot).
So i downloaded a VST-MIDI Monitor for Cubase to check in cubase itself. And there it tells me, that all signals are send on channel 1. And all needed note-off signals are there. That does not make sense.
In Music Maker 2013, where everything works just fine, i did the same and saw, that everything is like MIDI OX says, CHannel 5 and 1. But no never ending notes.

I hope anybody has a solution for this.
midi problem.PNG

It looks like you have 2 different zones configured on your midi controller? Is this intentionally? Because you are clearly sending the F via channel 1 and the A via channel 5. It would only make sense if you are recording 2 different vsts on different channels but I suspect this is not your intention in this case?

Start with the following: Make sure you have ‘midi thru’ deactivated in Preferences >> MIDI >> MIDI Filter. Hope this solves the issue, but you should look into the ‘key split’ sending out on 2 different zones on channels 1 and 5.

Why Cubase mirrors the note off message is not clear to me. It could mean that you unintentionally have some midi modifier active in the background of this project or it could be some corruption? Maybe try opening a completely new and blank project to see if this has the same issue?

Hey, I know I’m like 4 years late, but I was having this same issue as it relates to strings (I have NI Komplete). At seemingly random points, I noticed that certain strings (and some synths) just hit a note, and then stayed on, and wouldn’t turn off no matter what I did. I would have to completely shut the whole daw down to get them to stop, and reload my project.

I figured out though, that if you have a repeating note, and they overlap even the tiniest bit, it can cause this dual trigger to happen with no release, even if you pause the song, delete the midi line, or anything, aside from shutting down. So if you just make sure you either glue the two notes together, or create a tiny space between the two, it shouldn’t trigger like that, and should operate as normal.

Hope this helps, if anyone else stumbles on this thread, and is having the same issue. :slight_smile:

Same problem. Tried rebooting ipad. Tried deleting notes and playing them in again new. Song is finished but that last chord just won’t end! I do not speak technical, so I need a solution that tells me what button to push. Using Cubasis2 2.6 on an ipad. Does not occur on playback in Cubasis but is present in Mixdown M4A when I email to myself to put into iTunes.