midi out of vsti sequencer

I was trying to route the midi out of a vsti sequencer (I tried Clockwork and Appollo step sequencers). I load the sequencer vsti, create a midi channel (midi input from my keyboard, midi out to vsti sequencer). Load my sampler as a vsti and set the midi in for the sampler as “Midi out from vsti sequencer” and set the midi out to the sampler. I’ve tried all combinations of record enable. Am I missing something??

Yep, Cubase7’s internal vstbridge doesn’t quite get the midi out thing for some (all?) existing plugins. (It also seems unable to use vsti’s preset browsers and save functions, that is - vstbridge gets confused when it has to access file data from the computer).
JBridge needs to be used in order to get many VSTI’s midi out to actually transmit to another Cubase midi channel (even thought the vsti midi out shows in the midi in list for the track).

same appears to be true of using midi plugins (as vsti plug ins). Piz midi plug ins and toybear are a couple of examples…

I should clarify that I am running a 64bit host on Windows8.