MIDI output from inst track works fine on desktop, not on laptop (same version on both)

I’ve never run into this kind of issue before - I’m using the Sample Logic Animation Station arpeggiator and have it set up on an instrument track with some chords. I have a second track that takes MIDI data from the arpeggiator and that works just fine as long as the time signature is 4/4. The receiving track can be an instrument track or a MIDI track, doesn’t matter. The routing works fine.

However, if I switch to 7/8, the arp quits working on my laptop but works fine on my desktop. On my laptop, it plays the first note in the arp every time it gets a new chord but stops there.

Both my laptop and desktop are using 12.0.70.

Is there some setting somewhere that would make it work on my desktop but not my laptop?



Does the Instrument create a virtual MIDI Port? Does it create or on both systems?

Yes - the instrument creates a MIDI port and the routing works fine on both systems.

As I noted above, you can set it up in 4/4 and everything works perfectly. Then if you change to 7/8, and that is the only change you make, the arp never goes past the first step on my laptop. But it works fine on my desktop if you do exactly the same thing.

It has something to do with playback because I can play it live on both systems in any time signature and it works fine. The problem only occurs during playback, and only on my laptop.


Wired. I would get in contact with the plug-in’s support. To me it sounds like it’s on the plug-in side.

Maybe there’s some sync issue? On your desktop do you have setup synchronisation while on your laptop no? (Menu Transport → Project Synchronisation Setup) Just a wild guess, otherwise, what Martin suggests is the most logical thing to do.

Yeah I’ve been in contact with Sample Logic. They initially said it’s a routing issue (it’s not). Then they said they’ll look in to it, so I take that to mean they’re going to ignore it. In the meantime, I specifically bought their software for a project in 7/8 and I can’t get a refund. And there’s no demo. But I digress…

Yeah I checked all the synch settings and it’s exactly the same on both desktop and laptop.

Here’s a video showing how switching 4/4 to 7/8 causes the arp to stop working. That is literally all I did after loading up a new project and adding the arpeggiator. You can see that when it’s in 4/4 it steps through the pattern just fine. Then you switch to 7/8 and it plays the first step each time and stops. It does not do that on my desktop, only my laptop.

Yeah this one confuses the heck out of me.

Out of curiosity did you tried any other arp plugin? Like HY plugins, xfer Cthulhu, Stepic by Devicemeister etc? I see that this SL plugin is not in kontakt, and knowing that their products are/was vastly in kontakt framework I would be cautious for any plugin outside of K framework, especially considering that plugin is new on the market.

The strange is that on one environment works and on other don’t that is really odd. My experience using MIDI devices feeding into another instruments (mentioned above) is mixed, often have problems and not constant results when I have some huge latency plugins also had some inconsistencies when its starting from first bar and when loop/cycle is engaged. Mostly its like dodging the road bumps and when I record midi output to inst/midi track I feel some relief knowing that its over :smiley:

Also trying that in reaper or other host might be good to rule out where problem lays in.

Yes I tried the HY sequencer, Stepic and the Pigments arp as input to other MIDI tracks/instruments. They all work as expected for all time signatures on my laptop and desktop. I also tried about a dozen softsynths with built in arps and they all work fine as well.

There’s something about the SL arp that doesn’t like 7/8 on my laptop.

Tried different host? Reaper is light and easy to setup.