MIDI output goes missing when disabling INSTRUMENT TRACK

This is an old issue.

If you have several MIDI tracks pointing to an INSTRUMENT TRACK and you disable the latter, the MIDI output of the tracks goes “missing”. And if you enable the INSTRUMENT TRACK again, they are still missing and you have to make them point again to the instrument track manually.

I think this happens because CUBASE changes the ID of the VSTi when disabling, so as the ID is not the same, the MIDI Track doesn’t know where to point. This happens since I have CUBASE (version 9) and I think it’s time to solve it.

“Disable instrument track” is a great feature, but this makes it unusable in some contexts (like my own template).

Duplicate post

I know, but that post was in Cubase 9 forum, and this one is in Cubase 10 forum. The problem still persists in version 10, that’s why I post this and I wrote “this is an old issue”. Maybe wasn’t the best procedure to do so, however.