Midi output routing change when disable enable midi track

Hello
I am building a big template in VePro 7 and Cubase 10 pro. When I disable and enable a midi track in Cubase, the midi output routing changes? Can anyone help?

Hi,

Could you write, how exactly does it change, please? Is se set to No MIDI Port or always to the 1st MIDI Port in the list, or anything else?

Hello,
here the same huge problem with VEP7.
I cleared all my template and left only 1 channel (so it’s simple to understand).

Cubase loses the midi port when i disable and re-enable the midi track.
There is no expression map.

I can’t work this way!.

Here the youtube video link:
https://youtu.be/92dvbSTsGaA

Contact me if and i can send the project.

Hi,

I can confirm. It happens only if you have a “multi-MIDI-Port” device, like VSL or NI Kontakt, or HALion.

If you have common MIDI device with 1 MIDI Port, then it works as expected.

Reported to Steinberg CAN-25814.

Hi,

Sorry, I’m just wondering, what should it bring, if you disable a MIDI track? You don’t save any resources…

This problem is still not solved. Disabling vst instruments and re-enabling them causes Cubase to change the midi output on the corresponding midi channels to ports that do not seem to exist. Even reloading large templates can cause some output channels to change without any clear reason. This is quite bad for overall workflow.

Hi Martin ,

I’m working with a huge template (3000 tracks ) connecting with VEP 7 ,
my template works fine except the fact the external midi clock is unstable and when I loop a part of the session , my hardware synth are not in sync anymore when the loop comes back to the first bar .
So I tried to disable all my midi tracks and everything works fine , no clock issue anymore .
That’s why disabling midi track fix the clock issue and the weird behavior cubase has when you’re working with a big template .
Nevertheless , If I disable a midi track at a time , and I enable it , it keeps the output connection .
But if I Disable a bunch of midi tracks and I enable them , they loss the output connection .
Hope Steinberg will fix this bug in a next update . I’m currently using Cubase 11 .

Julien .

Hi,

I’m sorry, I still can’t reproduce it.

I mean, I tried to keep it simple, to be able to follow the steps. So I have 2 Instrument tracks and 2 MIDI tracks. Every single track is connected to other Instrument track. Then I disabled both MIDI tracks at once. Then I enabled both MIDI tracks at once. The MIDI Outs were connected properly.

I tried the very same, with Instrument Racks.

And I tried to disable the MIDI tracks one by one and enable them at once.

What am I missing, please?

Hi,

I got a video. The issue is not about the MIDI Output (they stay connected), but about the Audio Return Channels associated in the project’s window Inspector.

This is known and already reported issue. Thank you.