Midi Part Copy Question

Hello,

I am taking drum loops from Toonrack Superior 2 and placing them into Cubase Midi parts. When I copy the part within Cubase, the copied part has one less bar (2 vs 3) than the original part.

The weird thing is that if I make copies of the 2 bar copy, it stays two bars. But copying the original 3 bar copy always ends up being two bars. Can someone explain to me what’s going on?

Thanks in advance for anyone who helps. :smiley:

Can you upload a screenshot of the original 3-bar Part? (3 bars does seem to be a rather unusual length for a loop, however :wink: )

Thanks for your reply vic.

The original 3-part bar part in Cubase is the one on the left, where I dragged the loop from Superior to the midi track. The screenshot below is what I see in Superior 2.

Check out the size of bar 3-4 relative to the other sizes of the bars on the ruler. Why is there a larger gap between 3-4?

I now see that bar #3 in Cubase has 6 beats. Was it like that before the copy? (Create a Time Signature track in the Cubase Project, to see any changes)
What happens if you try to drag the bottom-right corner of the original Part (to extend it)? Does the 3rd bar actually contain anything? (try looking in the List Editor). (or maybe there is some hidden data in the first bar, and we are seeing only bars #2 and #3?)
Without actually having Superior Drummer here, it is a bit difficult to second guess what is going on there :wink:

I now see that bar #3 in Cubase has 6 beats. Was it like that before the copy? (Create a Time Signature track in the Cubase Project, to see any changes)

Thanks Vic. You’re right. When I created the Time Signature Track, it showed 6/4 time at bar 3. Weird.

Nevertheless, when I changed it back to 4/4 and copied and pasted the original loop, it still was only 2 bars long.

What happens if you try to drag the bottom-right corner of the original Part (to extend it)? Does the 3rd bar actually contain anything? (try looking in the List Editor).

When I drag the part, there’s nothing else there.


(or maybe there is some hidden data in the > first > bar, and we are seeing only bars #2 and #3?)
Without actually having Superior Drummer here, it is a bit difficult to second guess what is going on there > :wink:

That’s it. The List Editor shows only 2 bars…

…while the channel part Part shows 3 bars. Why is that?

There is no hidden data that I can find. There’s no part underneath the Superior loop part. Where else would I look?


Thanks again for your help. :smiley:

So it looks like there is no actual harm done :wink:.
For your own interest, starting from a new empty Project, drag that loop from Superior Drummer onto a MIDI track in Cubase, then export it as a standard MIDI file, then import that MIDI file. Does the import show 2 bars or three?

Thanks for your help again Vic.

I did the export/import of the part and it imported as 3 bars.

I thought I was doing something wrong, or misunderstanding something, but it looks like an oddity, unless somebody else steps up and sheds light on it. I hope if it is an oddity that somebody at Cubase/Toontrack looks into this.

Thanks again.

If you wish, upload that MIDI file… I’ll see if I can spot anything (no guarantees though :wink: )

Thanks vic. Here’s the attached file.
Superior 3 bar.mid (312 Bytes)

Imported your MIDI file into Cubase4 and Cadenza for Windows (http://www.kevinkemp.com/cadenza/index.htm). Both resulted 2 bars of MIDI notes.

Thanks Jarno,

Any idea why it looks like 3 bars, and takes up 3 bars, on first entry from Superior 2 to Cubase 6?

I must be missing something here. How do you figure the beginning of bar 1 to the beginning of bar 3 is 3 bars?

Excuse me, but can’t interpret your screenshot, because “Drums and Bass” (which doesn’t even show how many bars it is) and "Superior Drummer (which is clearly a 2-bar part … from start of bar 1 to end of bar 2) are visualized differently.

Exactly, Jarno. I was under the impression that the OP was referring to the “Superior Drummer” MIDI part as the one which was pasted directly from the Superior Drummer GUI. Obviously not 3 bars in length as he is suggesting. Perhaps he can clarify?

If I import that MIDI file here, via the Import menu, creating a new Project… it causes Cubase to hang here!.. before I get a chance to look at it. (Normally I can use that method without problem)
However, if I simply drag the MIDI file into an existing project, then it is perfectly ok… two bars long, and, indeed, no hidden events inside the MIDI Part. So I don’t know where those extra two beats are coming from in your Tempo/Master track.
(If you wish, can you upload another simple MIDI file that doesn’t make any use of Superior Drummer (e.g. a two-bar Part containing just 8th-notes)?.. see if I can at least import that without it hanging! :wink:.

Thanks Vic

Are you talking about the two beats in the List Editor?

Did you open the Part with the List Editor? If so, does the List Editor look different from the Part?

No, I was talking about that mysterious 6/4 bar between the two Parts in your original screenshot.

Did you open the Part with the List Editor? If so, does the List Editor look different from the Part?

It looks correct here… first event(note) starts at 1:1:1:0 (btw, I think that, from your screenshot, you simply didn’t scroll the page up to the top :wink: ), last note starts at 2:4:3:1.

I would still like to see this, too.

I created a MIDI track with Superior Drummer and used that exact same “groove” (still on Studio 5 here but I don’t think it should make a difference) and the only way I could drag and drop it and get “3 bars” (not really 3 bars but rather 12 beats) is if I did this with the signature track …

… and it had to be dropped onto bar 2 to produce that result. Otherwise it was always 2 bars (8 beats) in length.

I did somehow manage to import the 2 bar MIDI and get it to show up as 3 bars (12 beats) but I was trying so many different combinations of things I couldn’t remember what I did and could never reproduce it. I know it had something to do with a particular combination of signature track/bar offset changes and export options. I don’t recall if that was with your uploaded MIDI or with my export of the same “groove”.

I’m thinking you must have been playing around with some things you are not telling us or don’t remember doing. Remember, if you make changes to a signature track and then remove it the changes will still show on the ruler.

One way or another your file and mine of the same “groove” are identical.

As long as you make sure you don’t do anything strange with your signature track I don’t think you will have any problems.

Thanks Scab Pickens.

Yes, it is clear that I unwittingly changed the tempo, which stretched a bar. As you can see, there was a difference in the List Editor compared to the Part. However, I was having troubled updating the version 6.05 as well. So, there was an overall problem with Cubase for me as well. I contacted customer support and they had me do a full uninstall and a clean install, and then the 6.05 update and Voila!, the Part and the List Editor look identical.

Thank you, and all the people who showed and interest and helped me out. I appreciate it! :smiley:

Swurveman