Midi parts do not follow tempo change

In previous versions of Nuendo, any midi track would automatically follow a temp ± in BPM. In version 6 this appears not to be the case. My recorded midi parts do not follow any BPM change. How can this be fixed?

Make sure the track is in musical mode.

there is no musical mode on midi tracks or instrument tracks.

There is a Musical/Linear option on Midi Tracks.

However, it may be hidden in one of two ways:

1 Pull the divider between the track list and the timeline to the right,
until all the visible controls of the track can be seen.

2 If this does not reveal the Musical/Linear Button [either a music note or a clock icon],
then the control may be hidden in the Track Settings page.
Click on the black bar at the bottom of the track list, click on Track Control Settings,
select the Midi Tab, and make sure that “Toggle Time Base” is in the “Visible Control” box
rather than the “Hidden Control” box

the 2nd option worked to bring out the hidden setting. Thanks so much… appreciate it.