MIDI performance timing on Cubase 11

Hi there,

I was wondering if anyone can shed some light in something that bugs me.

My PC is very powerful and in reality I should have no issues, but, as per my experience, the more I use a Cubase session , the more problems I have.

Spikes, jumps, glitches, etc.

So I either delete preferences, which this seems to do the trick, or I have to put the Buffer Samples up as much as possible.

When the buffer is set to 512 or 1024, the MIDI is literally all over the place!

It lags terribly and when I play fast 16th notes are all out of time both when playing and how they are recorded.

At first I thought it was me maybe being rusty, but I reduced the buffer down to 128 samples and the performance felt and was recorded much better and far more accurately. I also did not use any plugins that could cause latency etc.

I have one electronic piano and one small Alesis keyboard, and both produced the same results.

The piano is connected via MIDI through my MOTU 828 mk3 Hybrid and is connected to my PC via USB and the Alesis is connected directly to my PC via USB.

I activated the System Timestamps for Windows Midi Inputs, use Device ‘Direct Music’ and system timestamps for ‘Direct Music’ inputs.

I always had the same issue, but I am running a pretty powerful PC at this point and I was hoping that the MIDI issues would be eliminated.

Am I missing something here? Anyone has 100% perfect timing when playing and recording with high Buffer Samples? If so, how?


Wow, very surprised that nobody is commenting on this?

Does that mean that everybody has no issues with the MIDI timing on Cubase, just me??

What you describe is normal. The higher the buffer size is the more latency you’ll get while playing a vsti in realtime. The lower it is, the more responsive it will be. That is normal.

But are you sure you’ve installed the latest driver and selected the correct ‘asio’ driver for your MOTU 828 in Cubase?

Indeed I did from MOTU’s official website. The audio works perfectly and so does the playback of VSTis. But recording via my piano and keyboard is a very messy job on high buffer sample settings…

Thing is, the Alesis is directly connected to my PC and it too has the same issues as my piano which goes via the MOTU sound-card.

And in reversal, when the buffer size samples are really low, the piano plays really well, so i don’t think it’s the MOTU.

But what is you issue then? As I described if you record on 512 or even 1024 it’s normal to expect higher latency. Generally you would record on 32~256. Higher settings like 512~1024 are considered for mixing purposes. Not for real time playing a vsti via midi. This is normal behaviour.

Well, here is the thing,

I can’t go down to 32 to 256 because the audio performance spikes like crazy.

I am working on film-scoring and I have to, most of the times, load very heavy VSTis.

When these are loaded, if I go down to 32 the program is unusable due to constant spikes and freezes.

So I have to remain @ 512-1024 in order to have a running Cubase…

It’s disappointing, having an 18 core PC, I would expect better performance…

Then something may be wrong with the configuration of your system? Make sure you have ‘Steinberg power scheme’ selected to make sure your system doesn’t go to sleep while running Cubase.

Or it could be that you use too many heavy Kontakt (?) libraries that take up more memory than you physically have? In that case you’re computer will start to use the swap file on your disk and slow down everything. In that case you’ll need more RAM.

OK, so , to clarify, by ‘Sleep’, you mean Windows shutting the computer down on ‘Sleep’ mode, or do you mean that some applications go to sleep as they are seemingly inactive even though the PC is running??

I am at 64 giga RAM, but I know I need to boost the RAM capacity…

No, by sleep I mean the processor cores are going into sleep state when not fully used. Not your entire pc. You can prevent this by choosing a power scheme like the Steinberg power scheme. Or create your own by power scheme that specifies that the processor cores should never go to sleep.
You can also configure this in the bios of your system.

You know, this makes complete sense with what I am experiencing in general, OK I will try that and see if it creates any better results, cheers for the tip!!

But I think you first have to establish if you’re not running too much heavy libraries at the same time?

Open a new empty project and see if you can play with 32…64…128 there?

Sure thing,

My card’s software only goes down to 64 buffer samples.

I did open a drum kit from Halion on an empty project, and had no issues what so ever at 64 - 96 or 128…

Thing is, I have to run many heavy libraries at the same time.

I am starting to think this is a RAM issue, and perhaps contact the PC company I got the machine from , inquire how to set up bios so that the cores never go to sleep…

Also, I forgot to mention, the Cubase Power Scheme makes no difference to any problems I am experiencing, it doesn’t improve any issues.

Yes, this could well be the case! Faulty ram happens sometimes?

Load a heavy project and see in ‘task manager’ how much ram you actually use?
If it’s well below your 64GB it’s a problem with your system or the configuration of it?
Or faulty ram?

Hope you get it sorted out soon? Good luck!

I will do, and thank you for all your help!!!

You’re welcome!

1 Like

I don’t really think it is a RAM issue, as you most likely would have issues with higher buffer sizes, too, or hard crashes/weird behaviour in the case of defect RAM.

Check the Cubase performance meter when at lower buffer sizes (e.g. 128). Is it the ASIO gard that is peaking or the realtime/peak bar? If the latter (which would be my guess), it means that your system can’t keep up with processing the realtime path of Cubase. That is something where many cores don’t help, if e.g., one of those cores is at or near max usage (you can check that in Task Manager, Performance tab, right click on the graph and select “display logical cores” or whatever it is called in english/your language)
If one core is maxed out, there is nothing you can do but look at the signal path of the track you have record enabled and see if there are too many cpu hungry plugins on that and remove/disable them for the time being.
If you already have some effect plugins with a high internal latency in the signal path, you should hit the “constrain delay compensation” button at the top left of the toolbar which will automatically disable plugins with a latency higher than x milliseconds (configurable in the Preferences somewhere).

1 Like

Hey, thanks for this tip, much appreciated!!

I usually don’t have any effects on VSTis and when I record , it’s very rare I use any plugins on individual tracks unless there is an issue with any EQing needed etc. and if so, it’s post-recording.

For instance, when I record some percussion e.g. from Heaviocity’s Damage, I just load the VSTi and record. But as I said on higher buffer sample rates, the performance part and the result, is just painful. When lowered I have a ton of spikes and on very low rates it’s unusable. But the sessions can be very heavy and so I have to have a high buffer sample rate or else it all goes to hell.

Just to understand this better,

On ‘Audio Performance’ I see:



Disc Cache

I am not quite sure how to tell from these meters which ones are for the ASIO Guard and which is for the real-time/peak bar?


Argh, I’m obviously not able to read properly… you wrote C11 in the title, and i was describing C12 :person_facepalming:
Not sure about C11 performance meter and its meaning anymore. Better check the task manager for saturated cores anyway.
You could just for fun try other ASIO guard settings, it is quick to do in the Studio setup.

1 Like

Hey, no worries.

I think I have found the solution to this issue,

I activated the Power Scheme and this seems to have solved the problem, I can go to low Buffer Samples now even on very heavy projects.

Strange because the Power Scheme had no effect before…anyhow, I can at least record with much less painful results.

Cheers guys, I appreciate all your help!!