MIDI piano file playing & re-recorded when trying to record analogue vocals

I’ve recorded a piano track or drums etc via midi to a new project.
When trying to then add analogue vocals to this file, the midi recorded sections play, but are also duplicated and re-recorded onto my vocal recording. Ie: when isolating the vocal track and replaying, i not only have the vocals, but a duplicate of my midi piano recording in that track.
How do I turn off my the midi recorded piano so that it doesn’t duplicate & become part of my analogue vocal recording file?
Thanks, Molly.
(Very new to Cubase 13)

Hi Molly and welcome to the forums!

Could you please tell us what audio interface you’re using? It sounds like there might be a settings related to it that is wrong.

1 Like

Thanks for the welcome!
Steinberg UR22

If you have the UR22 MKII, then you need to disable the loopback function.

image

Worked. Thanks Mlib.
Being it’s late I won’t get to fully try it tonight but will report back tomorrow.
Thanks for taking the time to help :pray:

1 Like