MIDI plays piano instead of drums

I know it’s an ultra simple problem of selecting the channel - but for whatever reason Cubase simply reverts back to channel one (back to the piano sound instead of drums).

I made a quick YouTube video:
https://youtu.be/0tFzvVvheE0

First, click the drum track. To the far left is the Inspector, this is what you’ll usually want to use to change MIDI channels. Click the top option (called Drum Set in your video) and you’ll be able to change the channel, right below the name of the plugin currently being used by the track.