MIDI port routing is lost after enabling disabled MIDI tracks and VST instruments - CUBASE 10.5.20

I got really excited reading this specific release note of 10.5.20 – I’m on OSX 10.14.6:
“MIDI port routing was lost after enabling disabled MIDI tracks routed to VST Instruments that support multiple input ports”.

It seems it’s not working correctly.

Try this:

  1. Create a 2 VST tracks loading Kontakt, let’s call them K1 and K2.
  2. Load a patch both on K1 and K2, doesn’t metter which patch of which library;
  3. Create 2 midi tracks, let’s call them MIDI K1 and MIDI K2.
  4. Assign midi track MIDI K1 to instrument K1 and MIDI K2 to K2.
  5. Disable both instruments, K1 and K2, BUT LEAVE midi tracks MIDI K1 and MIDI K2 enabled.
  6. Now enable in THIS SPECIF ORDER, first instrument K2 and then K1.

Result? Both midi tracks lost the connection.
The correct input midi assignment remains only if you enable a VST instrument in the opposite order you disabled them, so if you disable #1, then #2 and then #3, you have to enable first #3, then #2 and then #1.

In huge templates (2000+ tracks) with more than 100 VST instruments disabled would be very useful if the correct link could be established again.

The workaround to this is to enable all the midi tracks assigned to a specific VST instrument all together, midi tracks and VST at the same time.
In huge templates that’s not easy to do, especially when many “utility midi tracks” (like those one used to reset round robins etc) are hidden and maybe visually far away from the instrument itself.

The problems seems to be that every time you load a VST instrument, its “ID number” it’s potentially not the same, but the first number available when you enable it.
The solution to this could be assigning a fixed ID number to a VST instrument within a specific Cubase Project.

Hi,

This is known and already reported issue.

Thank you very much for your reply!
Sorry for opening this 3D.

Release notes:
“MIDI port routing was lost after enabling disabled MIDI tracks routed to VST Instruments that support multiple input ports”.

Isn’t that exactly what user dream was talking about? I had exactly those problems and stopped using MIDI tracks for multitimbrals in my template. Is the fix not working? Now I am slightly confused.

Hi,

I cannot reproduce it here. It works for me in Cubase 10.5.20.

Could you make a video screen recording, please? Maybe you do something slightly different from me, what is not described.

Thanks