MIDI Ports problem after upgrading my OS and to Cubase 6.5

I just had my DAW upgraded from XP 32-bit to WIN7 Home 64-bit.
At the same time, I upgraded from Cubase 5 to 6.5
When I open up Cubase 6.5 64-bit and click on Device Manager -> MIDI Port Setup the only ports showing are from my Motif XS-Rack. I use a Korg Triton Studio keyboard as well in my setup.
However, there are not input or output Triton ports showing in the MIDI Port Setup list.
Also when I create a new MIDI track and click on the output routing is shows only the Yamaha ports and shows an item that say Triton (Not connected).
The Triton is defined in my MIDI Device Manager as an installed device and if I Open the Device and click on Patch Banks and then expand the programs A, for instance, the mapping to my Korg instruments seems to be correct.
If I point the Output Routing in the MIDI track to my Motif R XS-1 and play on my Korg keyboard I can clearly hear all of the sounds from the Motif Rack. So it would appear that my keyboard is being recognized by Cubase.
Here is a link to my MIDI_Audio setup that I used under my 32-bit OS and Cubase 5 before the upgrade.
http://www.dandepolito.com/images/MIDI_Audio_Setup.jpg
I’ve triple checked the MIDI/Audio connections and they are the same as before.
Any idea why Cubase is telling me it can’t find the Korg?
Thx.

You are connecting (Triton MIDI in only) through the RME FireFACE. Does the Fireface 400 show up in your MIDI ports (Triton won’t). If not then it sounds like Windows 7 is not seeing the RME interface and that this is not a Cubase issue, but a Windows issue.

In your diagram you have the MIDI out of your keyboard driving the Motif. So the Motif sees your keyboard, but not Cubase. When you play the Keyboard, it directly drives the Motif and therfore you here the sounds. The MIDI is not directly conneted to the computer. I imagine it gets passed through on the MOTIF MIDI interface, but I’m not sure how the Motif interface works.

In summary you should have 2 MIDI interfaces showing up (according to your diagram). RME and Motif. Triton should not show up as it is interfaced through the RME in one direction and the Motif in the other direction.

Ron

If I were you, I’d connect the Triton to the RME only (MIDI in AND out), and leave the Motif connected by USB only. This is, if you don’t need to play Motif from Triton without PC on…

Hi Guys,
thanks for responding,
I will attempt to answer both in a common reply.

Ron,

Does the Fireface 400 show up in your MIDI ports

Setting up the MIDI as Arjan suggested,
http://www.dandepolito.com/images/MIDI_Audio_Setup_Update.jpg

I am seeing,
Device -----|I/O |- Port System Name -|- State
--------------±----±------------------------±---------
DirectMusic | In | Fireface MIDI port 1 | Active
DirectMusic | In | Fireface MIDI port 2 | Active
DirectMusic | Out | Fireface MIDI port 1 | Inactive
DirectMusic | Out | Fireface MIDI port 2 | Inactive

Arjan,
I still do not get any output from the Triton patches.
In a MIDI track inspector the Output Routing still showing Triton (not connected)

Other info,
I have Local Off on my Triton.
I also switched the MIDI cables thinking it might be a bad cable but I still get the same results,
Triton (not connected)

Any other ideas?
thx.

thx again.

OK - based on your latest configuration (as suggested by Arjan)

Devices->MIDI Device Manager
You have selected Triton. Have you selected the output for Triton in this dialog (I’m thinking you haven’t - that’s why your MIDI track says Triton (not connected)). I would assume that you would select Fireface MIDI port 1 here as that is what is connected to your Triton. This would cause any MIDI track assigned to the Triton to play sounds from the Triton.

Set up a MIDI track with the input from Fireface Port 1 and the output to Triton (which has now been assigned to Fireface Port 1).

If you want sounds from the motif instead, you Set the input of the MIDI track to Fireface Port 1 and the output to Motif.

Ron